Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Какое число будет напечатано на экране компьютера в результате выполнения фрагмента программы?

5-9 класс

Бейсик
a=5 : b=8
If b/2>=a-1 Then
a=b+5
b=b*2-a
Else
a=a*b
b=b-a
Endif
Print b

Паскаль
a:=5 ; b:=8 ;
If b/2>=a-1 Then
begin
a:=b+5;
b:=b*2-a;
end
Else
begin
a:=a*b;
b:=b-a;
end;
Writeln(b);

Dianaxxx1 18 мая 2013 г., 14:13:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dima7072006
18 мая 2013 г., 15:52:34 (10 лет назад)

ответ 3

вроде бы...............

 

+ 0 -
Svetyunussova
18 мая 2013 г., 16:24:59 (10 лет назад)

3 так как выполняется условие и проходит процедура 1 в которой b := 8*2 - 15

Ответить

Другие вопросы из категории

1. Видеопамять

компьютера имеет объем 512 МБ. Сколько графических изображений размером
350x420, палитра которых содержит 65 тыс. цветов, может храниться в памяти
одновременно?

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в

зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"

Читайте также

1. Выберите файл, созданный программой MS Access:

Варианты:
1) as.mdb
2) as.xls
3) as.doc
4) as.ppt

2.

Пользователь работал с каталогом
C:\Контрольные\Тесты\История\
Сначала он поднялся на один уровень вверх, затем еще раз поднялся на один
уровень вверх и после этого спустился в каталог Архив. Определите полное
имя каталога, в котором оказался пользователь.


Варианты:
1) C:\Контрольные\Архив\
2) C:\Контрольные\Тесты\Архив\
3) C:\Контрольные\Тесты\История\Архив\
4) C:\Архив\

3.

Какое число будет напечатано на экране в результате выполнения фрагмента
программы?
Бейсик
F=5
FOR K=9 TO 7 STEP -1
F=F+(K+1)
NEXT K
PRINT F
Паскаль
F:=5;
FOR K:=9 DOWNTO 7 DO
F:=F+(K+1);
WRITE(F);

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Дан фрагмент программы :

a:= 10 ; b:= a+1 : a:=b-a ; write (a,b)
Какие числа будут выведены на экран компьютера ?

ДАЮ 40 БАЛЛОВ! ПОМОГИТЕ ПОЖАЛУЙСТА!

1.Какое число будет выведено на экран после выполнения этого фрагмента программы?
write(1);
for i:=2 to 1 do
write (i);

2.Что будет выведено на экран в результате выполнения фрагмента программы
a:=5; b:=3;
write( a, '=Z(', b, ')' );
Здесь a и b — целые переменные.

3.Что будет выведено на экран в результате выполнения фрагмента программы
a:=5; b:=3;
write( 'Z(a)=', '(b)' );
Здесь a и b — целые переменные.



Вы находитесь на странице вопроса "Какое число будет напечатано на экране компьютера в результате выполнения фрагмента программы?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.