Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Еще одно задание за еще большее вознаграждение. Если можете сделать, делайте максимально качественно. Програмиравние на Паскаль.

5-9 класс

Разработка алгоритма или программы для решения задачи: «Решение квадратного уравнения с коэффициентами a, b, c», содержащей команды ветвления (операторы ветвления).

Ole83071 19 окт. 2014 г., 11:28:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zhjckfd12
19 окт. 2014 г., 12:16:56 (9 лет назад)

Program KVUR;
uses crt;
Var
  A, B, C, D, X1, X2 : Real;
begin
  writeln ('Введите коэффициенты квадратного уравнения A, B и C ');
  write ('A = ');  readln(a);
  write ('B = ');  readln(b);
  write ('C = ');  readln(c);
  if A=0 then
    if B=0 then
      if C=0 then writeln('Все три коэфициента равны нулю! X - любое число')
        else writeln('Корней нет! ')
      else
        begin
          X1:=-C/B;
          writeln('X=',X1);
        end
    else
      begin
        D:=B*B-4*A*C;
        if D<0 then writeln ('Корней нет!')
          else
            begin
              X1:=(-B+sqrt(D))/2/A;
              X2:=(-B-sqrt(D))/2/A;
              writeln ('X1=', X1:0:2, ' X2=',X2:0:2);
            end;
      end;
end.

 

Проверено на PascalABC - всё работает

Ответить

Читайте также

Постройте математические модели для приведённых ниже задач. Какой вы можете сделать вывод на основании полученных моделей ? а) первая

бригада может выполнить задание за А дней, а вторая - за Б дней.

За сколько дней обе бригады выполнят задание , работая вместе?

б) Два велосипедиста одновременно одновременно направились навстречу к друг другу из двух сел. Первый мог бы проехать расстояние между селами за А минут, второй за Б минут. Через сеолько минут они встретятся?

Напишите программу, которая позволит определить количество дней в течение заданного периода, в которые не было прибыли, и максимальную выручку за этот

период. Прибыль за день определяется как разность "выручка"-1000 (рублей) (если разность отрицательна, считать прибыль равной 0).

На входе программа получает период N

Постройте математические модели для приведённых ниже задач. Какой вы можете сделать вывод на основании полученных моделей ?

u>
а) первая бригада может выполнить задание за А дней, а вторая - за Б дней.За сколько дней обе бригады выполнят задание , работая вместе?
б) Два велосипедиста одновременно одновременно направились навстречу к друг другу из двух сел. Первый мог бы проехать расстояние между селами за А минут, второй за Б минут. Через сколько минут они встретятся?
Решите пожалуйста, очень надо!

информационное сообщение объёмом 1 Мбайт передается со скоростью 4 Кб/мин.определите время передачи информации.

и еще одно задание:

сколько Кб информации содержат сообщения следующего объёма? :

2^16 бит, 2^16 байт и 1/4 Мб. Помогите решить хотя бы одно задание!!!!



Вы находитесь на странице вопроса "Еще одно задание за еще большее вознаграждение. Если можете сделать, делайте максимально качественно. Програмиравние на Паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.