Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано натаральное число n записать его наоборот (информатика)

10-11 класс

234725e6712dtsafdaf 18 июня 2015 г., 10:36:06 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anar6
18 июня 2015 г., 11:50:35 (8 лет назад)

var a: string;
    i: integer;
begin
     readln(i);
     a := IntToStr(i);
     for i := length(a) downto 1 do
         write(a[i]);
end.

Как вариант. Строку считывать не стал, раз уж работаем с числом, то и вводится путь число:)

Ответить

Читайте также

1. Дано шестнадцатиричное число 12CD. Получить его двоичный аналог.

2. Дано десятичное число X=563. Представить его в ячейке.
3. Дано десятичное число X= -62. Представить его в восьмиразрядной ячейке.
4. Дана шестнадцатеричная запись числа X=FB32 в ячейке. Получить исходное число в десятичной системе.

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1)Сколько бит информации несёт каждое двузначное число(отвлекаясь от его конкретного числового значения)?

2)Какое количество вопросов достаточно задать вашему собеседнику,чтобы точно определить число и месяц его рождения?
3)Происходит выбор одной карты из колоды 32 карты. Какое количество информации мы получаем в зрительном сообщении о выборе определённой карты?



Вы находитесь на странице вопроса "дано натаральное число n записать его наоборот (информатика)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.