Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано: массив B(10) и число C

10-11 класс

Определить:

Vinogrado 03 окт. 2016 г., 6:06:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
граощдп
03 окт. 2016 г., 8:53:49 (7 лет назад)

var 
  B: array[1..10] of integer;
  i, c, p, s: integer;
begin
  write('C = ');
  readln(c);
  for i := 1 to 10 do begin
    write('B[', i, ']=');
    readln(B[i]);
    end;
  c := 1;
  p := 1; s := 0;
  for i := 1 to 10 do begin
    p := p * (B[i] - C);
    s := s + B[i];
  end;  
  for i := 1 to 10 do
    writeln('A[',i,']=',(s-p)*B[i]);
end.

Ответить

Другие вопросы из категории

у хозяина гостиницы есть ключи от комнат. На вид ключи неразличимы. сделав ключи, он надел их на кольцо и покрасил в два цвета. Какое наименьшее число

ключей может быть у хозяина гостиницы,чтобы он мог различать, какой из них от какой комнаты, если известно, что ключей больше двух.

Сколько байт в 2 Гбайтах?

а) 2 x 2^30
б) 2 x 2^3
в) 2 x 2^20
г) 2 x 2^31
Расширение архивного файла
а) avi
б) jpg
в) mp3
г) zip

Во время выполнения программа находится в
а) Кэш-памяти
б) Оперативной памяти
в) Буфере
г) Долговременной памяти

народ помогите с информатикой)

В следующем тексте речь идет о Московском метро. Постройте по этим данным таблицу:

Время в пути от станции Отрадное до станции Кутузовская составляет 37 мин. Время в пути от станции Театральная до станции Юго-Западная составляет 24 мин. Время в пути от станции Октябрьская до станции Отрадное составляет 32 мин. Время в пути от станции Курская до станции Кутузовская составляет 23 мин. Время в пути от станции Октябрьская до станции Кутузовская составляет 16 мин. Время в пути от станции Юго-Западная до станции Отрадное составляет 46 мин. Время в пути от станции Театральная до станции Отрадное составляет 27 мин. Время в пути от станции Октябрьская до станции Театральная составляет 13 мин. Время в пути от станции Курская до станции Отрадное составляет 28 мин. Время в пути от станции Театральная до станции Кутузовская составляет 19 мин. Время в пути от станции Октябрьская до станции Юго-Западная составляет 23 мин. Время в пути от станции Юго-Западная до станции Кутузовская составляет 33 мин. Время в пути от станции Курская до станции Театральная составляет 10 мин. Время в пути от станции Октябрьская до станции Курская составляет 10 мин. Время в пути от станции Курская до станции Юго-Западная составляет 32 мин.

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее

арифметическое.
2) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.



Вы находитесь на странице вопроса "Дано: массив B(10) и число C", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.