Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее

10-11 класс

арифметическое.
2) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

Apolulyakhova 09 окт. 2014 г., 20:27:25 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Robent01
09 окт. 2014 г., 21:12:45 (9 лет назад)

var
   i,s:integer;
   f: array[1..10]of string;
   b: array[1..10] of integer;
begin
for i:=1 to 10 do
  begin
  write('Введите фамилию: ');
  readln(f[i]);
  write('Введите баллы: ');
  readln(b[i]);
  s:=s+b[i];
  end;
writeln('Список попавших в интервал');
for i:=1 to 10 do
  if (b[i]>10) and (b[i]<30) then writeln(f[i]);
writeln('Среднее арифметическое: ',s/10)
end.

var
   i:integer;
   b: array[1..10] of integer;
begin
for i:=1 to 10 do readln(b[i]);
writeln;
writeln('Двухзначные:');
for i:=1 to 10 do
  if (b[i]>9) and (b[i]<100)
      then write(b[i],' ');
writeln;
writeln('Оканчиваются на 5:');
for i:=1 to 10 do
  if b[i]-int(b[i]/10)*10=5
      then write(b[i],' ');
end.

Если 5 включать, то последние строчки будут такие:

Ответить

Другие вопросы из категории

1. Какие из приведенных описаний являются неправильными и почему?

• var a: array [1..20] of integer;
• type myarray=array [1..20];
var b: myarray;
• var sd: array [1..n] of integer;
• var dd: array[1] of integer;

Решить графически

 3^{x} + 1= (x-1)^{2}

Звуковая плата реализует 16-

тибитное двоичное кодирование аналогового звукового сигнала. Это позволяет воспроизводить звук с ...



а) 8 уровнями интенсивности; б) 256 уровнями интенсивности;

в) 16 уровнями интенсивности; г) 65536 уровнями интенсивности.


Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

--- Задача 7 ---

Просмотрщик
текстовых файлов. Написать программу, которая позволяет просматривать текстовые
файлы (выводит на экран содержимое файла). Имя просматриваемого файла должно
вводиться с клавиатуры. Вывод содержимого файла произвести постранично.

Примечание:
Результат работы с данными вывести на экран и в новый файл. Файл с входными
данными имеет название INPUT.TXT для текстовых файлов.


на PascakABC оч нужно..плизз

Тема - обработка символьных величин на Паскале. Ввести свою фамилию, имя и отчество как одно текстовое данное, используя пробел как разделитель.

Вывести на экран - фамилию; - имя; - фамилию и инициалы.
не понимаю, если я даже и начну выводить фамилию, как сделать так. чтобы выделялось только до пробела? ведь фамилии у всех разные. а программа должна быть универсальной для всех фамилий (т.е. фамилия вводится с клавиатуры)



Вы находитесь на странице вопроса "1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.