Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

в комп.вводятся результ. экзаменов для 20 студентов.(10;30)Вывести на экран фамилит и результ.Вывести их среднее арифметич.

10-11 класс

Andrev8818 10 июля 2014 г., 11:00:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katara2100
10 июля 2014 г., 13:05:17 (9 лет назад)

var
  i:integer;
  s:real;
  r:array[1..20]of integer;
  f:array[1..20]of string;
begin
for i:=1 to 20 do
  begin
  write('Фамилия: ');
  readln(f[i]);
  write('Результат: ');
  readln(r[i]);
  s:=s+r[i];
  end;
s:=s/20;
writeln('Список:');
for i:=1 to 20 do  writeln(f[i],': ',r[i]);
writeln('Средний балл: ',s);
end.

Ответить

Другие вопросы из категории

Разработать словесный и графический алгоритм для двух функций при х принадлежит [-2,2] с шагом 0,2 R = K1 * Z1^2 - B * Z2 / ( K - Z3 ) ; В изменяется

от 10 до 1 с шагом -1 z1,z2,z3,k,K1-произвольно

1) В массиве А1, ... , Аn найти количество единиц, стоящих на чётных местах.

2) В массиве M1, ... , Mn вычислить сумму элементов до последнего нулевого

Книга содержит 1000 знаков, а алфавит состоит из 4 знаков, частота

встречаемости которых 0,2; 0,4; 0,15; 0,25. Какой общий объем

Составьте

программу, определяющую принадлежность точки А(х, у) окружности с центром
0(0; 0) и радиусом R.

В паскалеABC.

В ОС WINDOWS NT информация о паролях пользователей хранится:

(укажите несколько вариантов ответа)


1) В файле user.dat

2) В файле sam.sav

3) В файле sam

4) В файле system.dat

5) В файлах с расширением pwl

Читайте также

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

1) В компьютер вводится результат для 10 абитуриентов. Вывести на экран фамилии и результат тех, кто попадает в интервал ( 10, 30) Подсчитать среднее

арифметическое.
2) Дан массив из 10 элементов. Определить 2х значные числа и которые заканчиваются на цифре 5.

Тема - обработка символьных величин на Паскале. Ввести свою фамилию, имя и отчество как одно текстовое данное, используя пробел как разделитель.

Вывести на экран - фамилию; - имя; - фамилию и инициалы.
не понимаю, если я даже и начну выводить фамилию, как сделать так. чтобы выделялось только до пробела? ведь фамилии у всех разные. а программа должна быть универсальной для всех фамилий (т.е. фамилия вводится с клавиатуры)

В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в

первом потоке. Тестирование проводится по трём предметам, по каждому предмету абитуриент может набрать от 0 100 баллов. При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам тестирования не менее 30 баллов по каждому из трёх предметов, причём сумма баллов должна быть не менее 140. На вход программы подаются сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500. В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N. Далее следуют N строк, имеющих следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоящая не более чем из 15 символов, <Баллы> – строка, содержащая два целых числа, разделенных пробелом – баллы, полученные на тестировании по каждому из трёх предметов. При этом <Фамилия> и <Имя>, <Имя> и <Баллы> разделены одним пробелом. Пример входной строки: Романов Вельямин 48 39 55 Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, допущенных к сдаче экзаменов в первом потоке. При этом фамилии должны выводиться в алфавитном порядке.



Вы находитесь на странице вопроса "в комп.вводятся результ. экзаменов для 20 студентов.(10;30)Вывести на экран фамилит и результ.Вывести их среднее арифметич.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.