Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Ввести массивA(N,M). Определить количество положительных и отрицательных элементов.

10-11 класс

Nika01396 02 мая 2015 г., 1:41:00 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ДимаГерасимов
02 мая 2015 г., 3:58:26 (9 лет назад)

const n = 5;
var i, j, total_p, total_o: integer;
a: array[1..n, 1..n] of integer;
begin
  for i := 1 to n do begin
    for j := 1 to n do begin
      a[i, j] := random(20) - 10;
      write(a[i, j]:3);
      if(a[i, j] < 0) then inc(total_o)
      else inc(total_p);
    end;
    writeln;
  end;
  writeln('Кол-во положительных эл-тов: ', total_p);
  writeln('Кол-во отрицательных эл-тов: ', total_o);
end.

Ответить

Другие вопросы из категории

Дано задание "Составьте программу, определяющую, лежит ли точка с

указанными координатами X, Y на окружности радиуса R с центром в
начале координат." я её составил но почему у меня всегда получается что точка не лежит на окружности хотя она лежит. Может я где то ошибся ?

var


x,y,r:integer;


Begin


Write('Введите координату X: ');


Readln(x);


Write('Введите координату Y: ');


Readln(y);


Write('Введите длину радиуса R: ');


Readln(r);


If (sqr(x)+sqr(y))=r


then writeln('Точка лежит на
окружности!')


Else writeln('Точка не лежит на
окружности!');




End.

Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.

Если первое число четно, то выведите сумму этих четырех чисел.
Если второе и третье числа положительны,то выведите их среднее арифметическое.
Если выполняются одновременно два перечисленных выше условия, то выведите все четыре числа без изменения.
Иначе, выведите числа, противоположные исходным.
Составьте соответствующие отладочные примеры и проверьте работу каждой программы.

Читайте также

1)Ввести целое число и найти произведение его четных цифр. Пример: Введите целое число: 1234. Произведение четных цифр числа 1234 равно

6.

2)Ввести целое число и определить количество черных и нечетных цифр.

Пример:

Введите целое число :12547

количество нечетных цифр:3

количество четных цифр:2



Вы находитесь на странице вопроса "Ввести массивA(N,M). Определить количество положительных и отрицательных элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.