Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

трийка чисел (Т1, М1, С1) задае статовий час учасника, атрийка (Т2,М2, С2,)- фінішний час учасника 30 км ( години, хвилини, секунди).Перевірити

5-9 класс

корекність даних і знайти результат учасника.

Infinitua123 06 марта 2015 г., 22:28:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lera1500lam
06 марта 2015 г., 23:53:25 (9 лет назад)

Program Zadacha;
Var T1, M1, C1, T2, M2, C2, t, T3, M3, C3: Integer;
Label Start;
Begin
Start:
Write('T1 = ');
ReadLn(T1);
If(T1 < 0) Or (T1 > 23) Then
Begin
WriteLn('Error!');
Goto Start;
End;
Write('M1 = ');
ReadLn(M1);
If(M1 < 0) Or (M1 > 59) Then
Begin
WriteLn('Error!');
Goto Start;
End;
Write('C1 = ');
ReadLn(C1);
If(C1 < 0) Or (C1 > 59) Then
Begin
WriteLn('Error!');
Goto Start;
End;
Write('T2 = ');
ReadLn(T2);
If(T2 < 0) Or (T2 > 23) Then
Begin
WriteLn('Error!');
Goto Start;
End;
Write('M2 = ');
ReadLn(M2);
If(M2 < 0) Or (M2 > 59) Then
Begin
WriteLn('Error!');
Goto Start;
End;
Write('C2 = ');
ReadLn(C2);
If(C2 < 0) Or (C2 > 59) Then
Begin
WriteLn('Error!');
Goto Start;
End;
t := (T2*3600 + M2*60 + C2) - (T1*3600 + M1*60 + C1);
If t <= 0 Then
Begin
WriteLn('Error!');
Goto Start;
End;
T3 := t div 3600;
M3 := (t - T3 * 3600) div 60;
C3 := t - T3 * 3600 - M3 * 60;
WriteLn('Результат: ', T3,':', M3, ':', C3);
End.

Ответить

Другие вопросы из категории

Не могу решить, помогите пожалуйста

Какой объём информации в Кб передаётся
за 6 мин. 16 сек.,

при скорости передачи информации 8192 бит/с?

1)В графическом интерфейсе компьютерный объект обозначается.....

2)Средства, обеспечивающие взаимосвязь с элементами системы
3)Отдельные свойства объектов окружающего мира вызывают у нас.,.
4)Чувствительный образ объекта, в данный момент нами не воспринимаемово,но воспринятого ранее?
ПОМОГИТЕ ПЛИЗ!УЧИЛКА ЗАДАЛА ВОПРОСЫ!!!!

Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С,В которые содержат: массив В - четные элементы из

массива А в порядке их следования в массиве А, массив С- отрицательные элементы массива А в порядке, обратному их следованию в массиве А.

Читайте также

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округ

ляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км\ч, выведите YES, иначе выведите NO.

Программа получает на вход число проехавших автомобилей N (1=<N=<30), затем указывает их скорости. Значение скорости не может быть меньше 1 и больше 300.

Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать на языке Паскаль

Пример работы программы: (смотри во вложениях)

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

помогите пожайлуста))))))))))) Даны значения двух моментов времени, принадлежащих одним и тем же суткам: часы, минуты и секунды для каждого из

моментов времени. Известно, что второй момент времени наступил не раньше первого. Определите, сколько секунд прошло между двумя моментами времени. Программа на вход получает три целых числа — часы, минуты, секунды, задающие первый момент времени и три целых числа, задающих второй момент времени. Выведите число секунд между этими моментами времени.

ввод:1, 1, 1, 2, 2, 2

вывод: 3661

ввод:1,2,30,1,3,20

вывод: 50

это задача на pascal ABC



Вы находитесь на странице вопроса "трийка чисел (Т1, М1, С1) задае статовий час учасника, атрийка (Т2,М2, С2,)- фінішний час учасника 30 км ( години, хвилини, секунди).Перевірити", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.