Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Выяснить, пройдёт ли кирпич с рёбрами a, b, c в квадратное отверстие со стороной x.

10-11 класс

Арзу1 13 июля 2013 г., 9:16:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
нетника
13 июля 2013 г., 11:45:12 (10 лет назад)

Program help;
Uses Crt;
Var a, b, c, x : Byte;

Begin
Write('Введи a, b, c, x: ');
Readln(a, b, c, x);

If ((a <= x) and (b <= x)) or ((a <= x) and (c <= x)) or ((b <= x) and (c <= x)) then
Write('Пролезет')
Else
Write('Не пролезет');
End.

+ 0 -
Rezedakosova
13 июля 2013 г., 13:23:21 (10 лет назад)

Там надо составить несколько условий для прохода этого кирпича в отверстие. Т.е. если сторона  A проходит в это отверстие и если стороны B и С тоже проходят значит пройдет и так несколько условий. для каждой стороны получаеться

Ответить

Другие вопросы из категории

1.

Чему равно количество бит информации в сообщении “Ваня на олимпиаде по
информатике занял одно из 8 мест”?

написать программу для решения следующей задачи. В двумерном массиве,

состоящем из целочисленных элементов, поменять местами в каждой строке
наибольший и первый не принадлежащий интервалу (a, b) элементы.
(паскаль)

Читайте также

Даны действительные положительные числа а, b, с, х, у. Выяснить, пройдет ли кирпич с ребрами а, b, с в прямоугольное отверстие со сторонами х и у.

Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a,b,c, пройти через прямоугольное отверстие со сторонами х и y (при это

м стороны параллелепипеда параллельны сторонам отверстия). Считать, что при равенстве размеров отверстия и кирпича, кирпич не может пройти в отверстие.

Определите, может ли кирпич, имеющий форму прямоугольного параллелепипеда с ребрами a, b, c, пройти через прямоугольное отверстие со сторонами x и

y(при этом стороны параллелепипеда параллельны сторонам отверстия).Считать, что при равенстве размеров отверстия и кирпича кирпич не сможет пройти в отверстие.



Вы находитесь на странице вопроса "Выяснить, пройдёт ли кирпич с рёбрами a, b, c в квадратное отверстие со стороной x.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.