Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны действительные положительные числа а, b, с, х, у. Выяснить, пройдет ли кирпич с ребрами а, b, с в прямоугольное отверстие со сторонами х и у.

10-11 класс

Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

Ykropbob 10 мая 2015 г., 23:37:45 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tedik2013
11 мая 2015 г., 0:11:23 (8 лет назад)

var a,b,c,x,y:real;
begin
writeln('Введите рёбра кирпича через пробел');
readln(a,b,c);
writeln('Введите размеры дыры');
readln(y,x); 
if (a<c) and (b<c) then  begin if (a<x)and(b<y) or (a<y) and (b<x) then write('Пройдёт')end 
else  if (b<a) and  ((b<x)and(c<y) or (b<y) and (c<x) ) then  write('пройдёт')  
else if (a<y) and ((c<x)and(a<y) or (c<y) and (a<x)) then write('пройдёт') 
else write ('не пройдёт');
end.

Ответить

Читайте также

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

Составить программу для решения задачи: 1)Даны действительные, положительные числа x,y,z. Выяснить, существует ли треугольник с длинами сторон x,y,z. Если

треугольник, то является ли он равносторонним? 2)Дан одномерный массив. Найти количество смен знака между соседними элементами массива. Программа -Паскаль.

Помогите, пожалуйста(Паскаль):

Даны действительные положительные числа x



Вы находитесь на странице вопроса "Даны действительные положительные числа а, b, с, х, у. Выяснить, пройдет ли кирпич с ребрами а, b, с в прямоугольное отверстие со сторонами х и у.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.