Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ааа+ввв=сввс, составьте программу для определения цифр а,в,с

5-9 класс

Evgenia200 30 окт. 2014 г., 3:16:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Гоня
30 окт. 2014 г., 5:08:15 (9 лет назад)

uses crt;
var
i,j,a,b,c,s:integer;
begin
clrscr;
for i:=1 to 9 do begin
for j:=1 to 9 do begin
if i<>j then begin
s:=(i+i*10+i*100)+(j+j*10+j*100);
if ((s mod 100) div 10 = (s div 100) mod 10) and ((s div 100) mod 10=j) then begin
if (s mod 10=s div 1000) and ((s mod 10)<>j) and ((s mod 10)<>i) then
writeln(i, ' ', j, ' ', (s mod 10));
end;
end;
end;
end;
end.

Ответить

Другие вопросы из категории

Изначально

растровое изображение имело палитру 2 цвета. В процессе его преобразования
информационный объём увеличился в 8 раз. Сколько цветов стало в палитре?
ПОМОГИТЕ ПОЖАЛУЙСТА!КАК ПРАВИЛЬНО ОФОРМИТЬ И РЕШИТЬ?

Графическое изображение, содержащееся в коллекции Microsoft Office.

Устройство для демонстрации компьютерной презентации на большом экране.
Вид компьютерных программ, предназначенных для создания, обработки и хранения сообщений различных типов.
Графическое изображение, выставленное на слайд презентации из файла, место расположения которого известно пользователю.

Читайте также

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три

четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование: Количество: Цена,руб:
Красная шапочка 500 г k
Алые паруса 200 г a
Воронежские 100 г b
Чародейка 250 г m

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б



Вы находитесь на странице вопроса "ааа+ввв=сввс, составьте программу для определения цифр а,в,с", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.