Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Ребят, помогите с информатикой. Капец как надо...

10-11 класс

заполните массив из 8 чисел натуральными числами с клавиатуры найти сумму первых четырех и произведение последних четырех поменять первый и четвертый элемент массива найти среднее арифметическое 3 - 7 вывести все на экран

Djumagereev 06 окт. 2016 г., 9:27:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
L1a2r3i4s5a6193
06 окт. 2016 г., 10:26:07 (7 лет назад)

На каком языке?
Если на C++, то:
#include<iostream>
void main()
{
setlocale(0, "");
int i;
int mas[8];
for(i=0;i!=8;i++)
{
std::cout<<"Введите число номер "<<i+1<<" из 8 "<<std::endl;
std::cin<<mas[i];
}
int left=0;
fot(i=0;i!=4;i++)
left=left+mas[i];
 int right=0;
fot(i=0;i!=4;i++)
right=right+mas[i];
i=mas[1];
mas[1]=mas[4];             
mas[4]=i;
int ari=0;
for(i=0;i!=5;i++)
ari=ari+mas[i+2];
ari=ari/5;
std::cout<<"Произведение 4 левых чисел"<<left<<std::endl<<"Произведение 4 правых чисел"<<right<<std::endl<<"Средние чисело от 3 до 7 "<<ari<<std::endl;
fot(i=0;i!=8;i++)
std::cout<<mas[i]<<std::endl;
system("pause");
}

+ 0 -
BreakingBad000
06 окт. 2016 г., 12:13:16 (7 лет назад)

Комментарий удален

+ 0 -
Prizrak87
06 окт. 2016 г., 14:15:15 (7 лет назад)

Все) Ты знаешь как это делать?

+ 0 -
Dimabakhtigreev
06 окт. 2016 г., 16:10:55 (7 лет назад)

Комментарий удален

+ 0 -
Mur3
06 окт. 2016 г., 18:38:25 (7 лет назад)

Комментарий удален

+ 0 -
Ntpt2012
06 окт. 2016 г., 20:49:46 (7 лет назад)

На бейсике

Ответить

Другие вопросы из категории

1. Реферат учащегося по информатике имеет объем 30 килобайт. Каждая страница реферата содержит 40 строк по 64 символа в каждой, мощность алфавита - 256

символов. Найдите количество страниц в реферате.

2. Какой объём видеопамяти необходим для хранения четырёх страниц изображения при условии, если битовая глубина равна 16, а разрешающая способность дисплея равна 640*350 пикселей.

3. Опишите в виде графической схемы процесс варки яиц вкрутую.

Пожалуйста помогите с программой по информатике!(

Задана последовательность целых чисел(ввод с клавиатуры),количество которых не превосходит 100.Требуется расположить элементы последовательности в возрастающем порядке.

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить. На

острове каждый год появляется сундук с 100 кг золотого песка, к острову с одной стороны высаживается х пиратов, а с другой у матросов. Они дерутся за клад, в битве погибает 70% участников, 26% тяжело ранены. Монеты делятся среди оставшихся 4%. Определить количество победителей, тяжелораненых, погибших, а также количество золотого песка на 1 человека .

Задания за 9 класс. Ребят, помогите, пожалуйста. С Exel работать надо, на компьютере его нет (на windows 8 перешла), к тому же, честно говоря, не умею им

пользоваться. Добрые люди, пожалуйста, помогите :с Завтра сдавать :с

Здравствуйте ребят! Помогите решить задачку..Мне её надо написать в С++. Честно говоря хотя бы напишите мне "Дано" и как это решить.

=)

На концерте певицы было А % отдыхающих в санатории, на выступление хора зрителей собралось в 1,5 раза больше. Сколько зрителей побывало на этих концертах, если всего в санатории отдыхало х человек.

Помогите решить задачку очень-очень надо:)) спасибо:* Устав от повседневных дел, Иван Петрович устроил себе отпуск - пошел на охоту. На

расстоянии N метров, его охотничья собака Гайзарда заметила зайца. Через какое время она догонит его если скорость зайца V1 м / с, а скорость собаки V2 м / с? Следует отметить, что Гайзарда бегает быстрее любого зайца.
Входные данные:
Программа на вход получает три целых числа N, V1, V2 (0 ≤ N ≤ 103, 0 <V1, V2 <20).
Выходные данные:
Программа должна вывести время за собака догонит зайца с точностью до сотых.



Вы находитесь на странице вопроса "Ребят, помогите с информатикой. Капец как надо...", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.