Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста составить программы: 1) Определить сколько трехзначных чисел кратны m 2) Определить сколько трехзначных чисел

5-9 класс

содержат цифру 3

BeligtoBaglaev 15 февр. 2014 г., 10:46:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Diemianlisin
15 февр. 2014 г., 12:13:03 (10 лет назад)

1)

var
i,m,n:integer;
begin
read(m);
for i:=100 to 999 do
if i mod m = 0 then
n:=n+1;
writeln(n, 'chisel kratno')
end.

2)

var
i,m,n:integer;
begin
for i:=100 to 999 do begin
if (i mod 10 = 3) or ((i mod 100) div 10 = 3) or (i div 100 = 3) then
n:=n+1;
end;
writeln(n, 'chisel soderzit')
end.

Ответить

Читайте также

Напишите программу, которая в последовательности целых чисел определяет количество трехзначных чисел, кратных 7. Программа получает на вход целые

числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000. Про-грамма должна вывести одно число: количество трехзначных чисел, кратных 7

Составить программу которая определяет сколько тыс.руб пропали сегодня в столовой из-за отсутствия на занятиях некоторых учащихся по неизвестной причине.

Программа должна спрашивать:
- сколько человек было поставлено на заявку.
- сколько человек присутствовало на занятиях.
- сколько стоит обед для одного учащегося.
Помогите пожалуйста, очень нужно, только правильно, заранее спасибо.

Составьте программу, которая определяет, сколько раз встречаются числа x,y, x-y,x+y в последовательности из 50 заданных чисел. Данные с

клавиатурызадаются в таком порядке: x y и 50 чисел. Помогите, пожалуйста, очень надо)

ребят, помогите пожалуйста, ну ооочень нужно, от этого зависит аттестуют меня или нет, заданий правда много, и пожалуйста, не пишите херню либо очень

мало
эти задания нужно сделать циклами while и for, т е чтобы получилось 12 программ

1. Составьте программу вычисления значения функции: y=7x^2+1/x^2-16
2. Составьте блок-схему алгоритма и программу расположения четырех чисел в порядке возрастания.
3*. Составьте программу, определяющую вид треугольника по трем его сторонам A, B, C.

4. Составьте блок-схему алгоритма и программу вывода на экран всех трехзначных чисел, кратных 7.
5. Составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел, кратных 13.
6*. Составьте программу вывода на экран таблицы степеней 2ⁿ, где 0 ≤ n ≤ 10.

я вас просто умоляю, напишите, пожалуйста



Вы находитесь на странице вопроса "Помогите пожалуйста составить программы: 1) Определить сколько трехзначных чисел кратны m 2) Определить сколько трехзначных чисел", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.