Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Найти произведение и количество нечетных чисел из n введенных с клавиатуры

5-9 класс

Vikochka0160 08 нояб. 2014 г., 22:22:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ilyaloma
08 нояб. 2014 г., 23:28:32 (9 лет назад)

0-конец ввода.
program z4;
var a,w:integer;
begin
  a:=100;
  w:=0;
  while a<>0 do begin
  readln(a);
  if a mod 2 <> 0 then w:=w+1;
  end;
  writeln(w);
end.  

Ответить

Другие вопросы из категории

срочно, ребят!!!

в гонке участвуют 46 автомобилей для кодирования их номеров используется минимально возможно кол-во бит. какой общий объем информация в байтах сохранит автомат. устройство инф. после достижения финиша всех машин?

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

1.Найти произведение всех целых чисел от а до 100 (а<100) кратных 17,но не кратных 2 2.Вычислите: 98+96+94+92+90+88+,,,,,+6+4+2

3.Определить и вывести на экран количество трехзначных чисел,которые делятся без остатка на 5 и 21 одновременно.

4.спортсмен пробежал в 1-ый день тренеровки расстояние 10 км. В каждый следующий день он робегал на 3 км больше ,чем в предыдущий. Определить Суммарное расстояние.

5. в Пионерском лагере n отрядов с различным количеством детей. Сколько всего детей в пионерском лагере?

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);

Технология надо написать блог схему и программу.

найти произведение нечетных чисел из диапазона от m до n



Вы находитесь на странице вопроса "Найти произведение и количество нечетных чисел из n введенных с клавиатуры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.