Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Подсчитать сумму вводимых чисел до первого отрицательного числа (использовать цикл с постусловием).

10-11 класс

KiraFranky 17 апр. 2013 г., 4:51:37 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chelavip
17 апр. 2013 г., 6:42:50 (11 лет назад)

 program summa;
 var a:= 0;
 var b:= 0;
 begin
  writeln('Введите число');
   readln(a);
   if a>0 then  
    repeat {повторяй}
      a:= a+b;
   writeln('Введите еще число');
   readln(b);  
   until (b<0); {до тех пор, пока условие не будет истинным}
     writeln('Было обнаружено отрицательное число');
        if a>0 then 
     writeln('Полученная сумма: ',a)
     else writeln('Отрицательное число было первым');
     readln;
 end.
Программа на выходе сообщает:
Введите число
3
Введите еще число
45
Введите еще число
9
Введите еще число
-8
Было обнаружено отрицательное число
Полученная сумма: 57

+ 0 -
Vika593
17 апр. 2013 г., 9:21:40 (11 лет назад)

НА паскале

Ответить

Другие вопросы из категории

Напечатать в возрастающем порядке

все трёхзначные числа,в десятичной записи кот. нет одинаковых цифр

инфор-ая емкость дискеты
Что такое сокет процессора?

Читайте также

1. В последовательности чисел подсчитать произведение чисел, кратных 3.

2. В последовательности чисел сравнить, что больше сумма положительных или про-изведение отрицательных.
3. В последовательности чисел определить предпоследнее отрицательное число. (При решении введите дополнительную переменную для хранения предпоследнего отрицательного числа).

Опять-таки нужна программа в среде паскаль



На
вход поступает первое число - колличество чисел в
последовательности.Затем вводится последовательность.Подсчитать сумму
чётных чисел больше 30 в последовательности.

Нужно разработать программу для определения требуемых величин в элементах двумерного массива, расположенных ниже главной и побочной диагонали.

Имя массива J

Размер 32

Программа должна реализовывать следующие функции:

1.Сумма всех чисел

2.минимальное чётное число

3.кол-во отрицательных нечётных чисел

4.сумма отрицательных нечетных чисел

Паскаль

Помогите пожалуйста 10 класс . много чего ещё не понимаю
1) Определите сумму четных чисел до числа N введённые с клавиатуры
N=10
S=2+4+6+8+10=30
2) Составить программу которая вводит с клавиатуры число N и определяет произведение всех чисел
N=4
P=1*2*3*4=24
помогите пожалуйста

Написать программу на Pascal ABC.Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов,

произведение и количество отрицательных элементов, произведение элементов до
первого отрицательного. Отсортировать массив по возрастанию.



Вы находитесь на странице вопроса "Подсчитать сумму вводимых чисел до первого отрицательного числа (использовать цикл с постусловием).", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.