Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Паскаль

10-11 класс

Помогите пожалуйста 10 класс . много чего ещё не понимаю
1) Определите сумму четных чисел до числа N введённые с клавиатуры
N=10
S=2+4+6+8+10=30
2) Составить программу которая вводит с клавиатуры число N и определяет произведение всех чисел
N=4
P=1*2*3*4=24
помогите пожалуйста

Sashkoooa 04 нояб. 2014 г., 8:36:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Данил5567
04 нояб. 2014 г., 10:20:36 (9 лет назад)

Program enot;
Var n,s,i:integer;
begin
read(n);
s:=0;
for i:= 1 to n do
  if i mod 2 = 0 then
s:=s+i;
writeln('summa = ',s);
end.  

2.

Ответить

Другие вопросы из категории

Для кодирования букв O, P, S, T использовали двухразрядные последовательные двоичные числа (от 1000 до 1011 соответственно). Закодируйте этим кодом

последовательность символов STOP. результат запишите шестнадцатеричным кодом

плиз помогите как сделать!?
Здравствуйте , задача 6.2 не работает , можете помочь , и желательно с объяснением . =) Я попробовал в Pascal ABC запустить , и она выдаёт пустое

окно .
function len(s: integer): byte;
var i, l: byte;
begin l := s;
while (l > 0) do
begin
l := l div 10;
inc(i);
end;
len := i;
end;
var i: integer;
begin i := 3;
repeat
i := i * 3;
until (len(i) = 6);
writeln(i);
end.

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.