Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу которая будет решать эти задачи с оператором цикла for или while задачи на картинки

5-9 класс

Vaniaz 19 июня 2013 г., 1:32:56 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dima1234567890f
19 июня 2013 г., 4:32:52 (10 лет назад)

Задача №2
uses crt;var  x,i: integer;  begin cls;  write('x= '); readln(x);  for i:=1 to x do    if (x mod i)=0 then writeln(i);end.
Задача №1
uses crt;var  x,a,b,c,i: integer;  begin cls;  for i:=100 to 999 do  begin   a:= i div 100;   b:= (i - a*100) div 10;   c:= (i - a*100 - b*10);   if (a+b+c)*(a+b+c)*(a+b+c)=i then   begin    writeln(i);    inc(x);   end;  end;  if x=0 then write('Такого числа нет');end.
Задача №3
uses crt;var  x,a,b,i: integer;  begin cls;  for i:=10 to 99 do  begin   a:= i div 10;   b:= i - a*10;   if a=(b*2) then writeln(i);  end;end.

Ответить

Другие вопросы из категории

Читайте также

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1. Напишите программу, которая вводит трехзначное число и разбивает

его на цифры. Например, при вводе числа 123 программа должна
вывести 1, 2, 3.
2. Напишите программу, которая вводит возраст человека (число, не
превосходящее 120) и выводит на экран этот возраст со словом «»год,
«года» , «лет» . например «21 год», «22 года», «15 лет»

Помогите пожалуйста !!!!

а)Одномерный массив A заполнен десятью случайными целыми числами от 1 до 20. Напишите программу вывода элементов массива в обратном порядке.

б)Напишите программу, которая массив из 20 элементов заполнит неповторяющимися целыми числами и выведет на экран элементы с нечетными индексами.

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0



Вы находитесь на странице вопроса "Напишите программу которая будет решать эти задачи с оператором цикла for или while задачи на картинки", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.