Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано четырехзначное число. Определить, кратна ли трем сумма его цифр. Написать программу в паскале. Не используя массивы и циклы.

5-9 класс

NurkhaN1221 06 авг. 2013 г., 0:03:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
янидач
06 авг. 2013 г., 1:14:05 (10 лет назад)

var s, a: integer;
begin
readln (a);
s:=adiv1000+adiv100mod10+amod100div10 + amod10;
if s mod 3=0 then writeln ('сумма кратна 3') else
writeln ('сумма не кратна 3');
end.

Ответить

Читайте также

Программу надо написать в PascalABC, с использованием команд repeat и until. Ввести натуральное число и определить, какие цифры встречаются несколько раз

(с защитой от неверного ввода) или Ввести натуральное число и определить, верно ли, что сумма его цифр равна 10 (с защитой от неверного ввода).

НУЖНО НАПИСАТЬ ПРОГРАММЫ НА ПАСКАЛЕ "циклы с условием" 1)Среди чисел 1, 4. 9. 16, 25,... найти первое число, большее n. 2)Дано число

n.

а) Напечатать те натуральные числа, квадрат которых не превышает n.

3) Дано натуральное число. Определить:

а) количество цифр 3 в нем;

г) сумму его цифр, больших пяти;



Вы находитесь на странице вопроса "Дано четырехзначное число. Определить, кратна ли трем сумма его цифр. Написать программу в паскале. Не используя массивы и циклы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.