Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан ряд Фибоначчи. Найти n-элемент решения.

5-9 класс

Nomadu 21 июля 2016 г., 6:33:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АлександрРед007
21 июля 2016 г., 7:39:45 (7 лет назад)

# include <stdio.h>
int phi(int x){
int i,k=0;
if(x>1)k+=phi(x-1)+phi(x-2);
if(x<2)k=x;
return k;}    
int main (void){
int x;
scanf("%d",&x);
printf("%d",phi(x));
return 0;}

Ответить

Другие вопросы из категории

В классе 35 учеников, каждый из которых любит футбол, волейбол или баскетбол, а некоторые – два или даже три из этих видов спорта. 24 ученика любят

футбол, 18 – волейбол, 12 – баскетбол. При этом 10 учеников одновременно любят футбол и волейбол, 8 – футбол и баскетбол, а 5 – волейбол и баскетбол. Сколько учеников этого класса любят все три вида спорта?

Составить программу вычисления значения функций

3х+с, если с<х
y{ x/c если с>=x

дайте наиболее точное общее имя каждой группе объектов

1.канада,сша,мексика-
2.амазонка,енисей,нил-
3.волга,амур,иртыш-
4.лаура,эльба,висла-
5.принтер,монитор,клавиатура-
6.клавиатура,сканер,мышь-
7.берёза,жасмин,ромашка-
8.яблоня,груша,вишня-

Читайте также

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Дан массив из 8 целочисленных элементов. Элементы вводятся с клавиатуры (все элементы

различны). Найти минимальный элемент численного массива и его порядковый номер.

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

Вычислить среднее арифметическое значение тех элементов одновременного массива, которые попадают в интервал от -2 до 10. Размерность массива произвольная.

ИЛИ Дан массив, содержащий 12 элементов и заполненный по формуле A=(i-4)/(3*i). Найти количество элементов в этом массиве больших 0, но меньших 0,2. (решение писать как в турбо паскале)



Вы находитесь на странице вопроса "Дан ряд Фибоначчи. Найти n-элемент решения.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.