Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Вычислите Y для всех значений переменной X. Pascal abc.

10-11 класс

DOGHELPER 05 окт. 2013 г., 15:03:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Леся200
05 окт. 2013 г., 17:57:14 (10 лет назад)

var
x,y1,y2:real;
begin
if (x>1)and (x<5) then y1:=2/x else y1:=sqr(x);
if (x>15)and (x<>25) then y2:=sqrt(x) else y2:=sqr(x);
writeln (y1,' ',y2);
end.

Ответить

Другие вопросы из категории

Дано квадратное уравнение вида A*x^2+B*x+C=0

Коэффициенты заданы A= 4.00 B= -52.00 C= 144.00
A>0, D>0. Формулы для помощи: d=B^2 - 4*a*c; x1,2=(-b +- Sqrt(d))/(2*a)
Вывести вначале меньший корень, затем больший.
Нужно написать программу в Pascal'e.

В результате сканирования с разрешением 72 dpi было получено изображение, которое затем распечатали на принтере с разрешением 600 dpi. Что произойдет с

изображением при печати?

1) Качество печати изображения будет высоким, размер рисунка на бумаге не изменится.

2) Качество печати изображения будет высоким, размер рисунка на бумаге изменится.

3) Качество печати будет значительно хуже изображения, размер рисунка на бумаге не изменится.

4) Качество печати будет значительно хуже изображения, размер рисунка на бумаге изменится.

Читайте также

Укажите значения переменных K, L, M, N, при которых логическое выражение (K → M) \/ (L /\ K) \/ ¬N ложно.

Ответ запишите в виде строки из четырех символов: значений переменных K, L, M и N (в указанном порядке). Так, например, строка 1101 соответствует тому, что K = 1, L = 1, M = 0, N = 1.

1)Определите значение переменной c после выполнения следующего фрагмента программы:

a :=40 ;
b := 10;
a := - a / 2*b,;
if a > b then
c := b - a
else c := a - 2 * b

2)Определите значение переменной c после выполнения следующего фрагмента программы:
a := 5;
a := a + 6;
b := - a;
c := a - 2 * b

Укажите значения переменных K, L, M, N, при которых логическое выражение (¬(M V

L) /\ K) ((¬K /\¬M) \/ N)

ложно. Ответ запишите в виде строки из четырех символов: значений переменных K, L, M и N (в указанном порядке). Так, например, строка 1101 соответствует тому, что K=1, L=1, M=0, N=1.

1)написать программу, которая вычисляет произведение сумм всех соседних пар целых чисел из диапазона от 12 до 36 и выводит значения тех сумм, которые

меньше 52.

2)В результате работы некоторой подпрограммы вычислены значения четырех переменных a, b, c, d. Написать на предложенном в пункте а) языке программирования программу, после работы которой в случае, если сумма положительных значений (среди a, b, c, d) больше 20, значение g равно наибольшему из a, b, c, а в остальных случаях значение g равно значению d. (В программе можно использовать новые переменные.)



Вы находитесь на странице вопроса "Вычислите Y для всех значений переменной X. Pascal abc.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.