Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дано квадратное уравнение вида A*x^2+B*x+C=0

10-11 класс

Коэффициенты заданы A= 4.00 B= -52.00 C= 144.00
A>0, D>0. Формулы для помощи: d=B^2 - 4*a*c; x1,2=(-b +- Sqrt(d))/(2*a)
Вывести вначале меньший корень, затем больший.
Нужно написать программу в Pascal'e.

Mac72 05 сент. 2013 г., 11:41:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vosyvala
05 сент. 2013 г., 14:10:37 (10 лет назад)

Как-то так крч=)

program z1;
var a,b,c,d,x1,x2:real;
begin
a:=4.00;
b:=-52.00;
c:=144.00;
d:=b*b - 4*a*c;
x1:=(-b+ Sqrt(d))/(2*a);
x2:=(-b- Sqrt(d))/(2*a);
if x1>x2 then begin
writeln('Меньший корень',x2,'Больший корень',x1)
end else
writeln('Меньший корень ',x1,'Больший корень ',x2);
end.

Ответить

Другие вопросы из категории

В результате сканирования с разрешением 72 dpi было получено изображение, которое затем распечатали на принтере с разрешением 600 dpi. Что произойдет с

изображением при печати?

1) Качество печати изображения будет высоким, размер рисунка на бумаге не изменится.

2) Качество печати изображения будет высоким, размер рисунка на бумаге изменится.

3) Качество печати будет значительно хуже изображения, размер рисунка на бумаге не изменится.

4) Качество печати будет значительно хуже изображения, размер рисунка на бумаге изменится.

Читайте также

Помогите пожалуйста, очень нужно!

Программирование
Решить квадратное уравнения вида ax^2 + bx + c = 0
К решению математическая модель:
Дано:
Нужно:
Связь:
При:

Опишите на рускком языке или в виде блок-схемы алгоритм решения обобщенного квадратного уранения: ах²+bх²+с=0 В обобщенном квадратном уравнении любой

из коэффициентов может равняться нулю(в том числе и все одновременно).

Распишите именно как сдавать,на чистовик,не что нужно делать,а именно как в задании.

Написать программу для паскаля. Дана квадратная матрица

порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

Задан вид квадратного уравнения ах квадрат +bx+c=0, коэффициенты a,b,c. Найти корни уравнения x1,x2.

1. Разработать схему алгоритма программы
2. Составить программу на языке Паскаль по разработанному алгоритму

Помогите пожалуйста!)

Задание 3.
Дана квадратная матрица размерностью N. Подсчитать количество отрицательных элементов по строкам. ВВЕДИТЕ РАЗМЕРНОСТЬ МАТРИЦЫ N:-
->5
Через пробел введите N*N элементов массива:
--> 10 3 2 6 8
3 -2 7 -1 4
4 5 -10 9 -12
5 0 2 4 5
6 3 -3 -5 2
Количество: 0,2,2,0,2



Вы находитесь на странице вопроса "Дано квадратное уравнение вида A*x^2+B*x+C=0", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.