Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Задан вид квадратного уравнения ах квадрат +bx+c=0, коэффициенты a,b,c. Найти корни уравнения x1,x2.

10-11 класс

1. Разработать схему алгоритма программы
2. Составить программу на языке Паскаль по разработанному алгоритму

Semensolomen 15 окт. 2013 г., 17:07:41 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ilvinashakirov
15 окт. 2013 г., 19:39:52 (10 лет назад)

var a,b,c,d,x1,x2:real;
begin
writeln('Решение квадратных уравнений'); 
writeln('');
writeln('Введите коэффициенты a,b,c:'); 
readln(a,b,c);
d:=sqr(b)-4*a*c; 
if d<0 then  writeln('Корней нет'); 
if d=0 then begin  x1:=-b/(2*a); 
 writeln('Один корень:'); 
 writeln(x1:4:2);  
 end; 
if d>0 then begin 
 x1:=-b+sqrt(d)/(2*a);  
 x2:=-b-sqrt(d)/(2*a); 
 writeln('Корни уравнения:'); 
 writeln(x1:4:2); 
 writeln(x2:4:2); 
 end;
end.

Ответить

Другие вопросы из категории

Сделайте архивный файл (rar) через консоль Windows (cmd). В файл поместите doc-документ, содержащий ваши Ф.И.О, номер группы и текст команды, которую вы

используете.


Объясните пожалуйста как это сделать , какую именно нужно команду ввести .... в Инете искал не нашёл )) помогите поже...

"Шифры замены". Каждая буква алфавита может быть заменена любым числом из соответствующего столбика кодировочной таблицы.А Б В Г Д Е Ж З И К Л М Н О П Р

21 37 14 22 01 24 62 73 46 23 12 08 27 53 35 04
40 26 63 47 31 83 88 30 02 91 72 32 77 68 60 44
10 03 71 82 15 70 11 55 90 69 38 61 54 09 84 45

С Т У Ф Х Ц Ч Ш Щ Ъ Ы Ь Э Ю Я
20 13 59 25 75 43 19 29 06 65 74 48 36 28 16
52 39 07 49 33 85 58 80 50 34 17 56 78 64 41
89 67 93 76 18 51 87 66 81 92 42 79 86 05 57
Рис. 4.


Какие сообщения закодированы с помощью этой таблицы?16 55 54 10 69 09 61 89 29 90 49 44 10 08 02 73 21 32 83 54 74
41 55 77 10 23 68 08 20 66 90 76 44 21 61 90 55 21 61 83 54 42
57 30 27 10 91 68 32 20 80 02 49 45 40 32 46 55 40 08 83 27 17

Заполнить массив из 10 элементов случайными числами в интервале [-10..10] и найти в нем два максимальных элемента и их номера.

Пример: Исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0 максимальные a[4]=10, a[7]=8

в чем сходство CD и DVD ? в чем их различие ?

таблица
характеристика СD DVD

различие

Читайте также

Задание: разработать программу вычисления выходного значения функ-ции y=f(x1,x2,x3,x4). Тип входных и выходных данных, вид функции заданы в табл. 2.

Выходное значение и входные должны отображаться на экране в виде: X1= X2= X3= X4= Y=

Разработать функцию, которая автоматически заполняет массив из 10 наборов входных данных. Массив затем подвергается обработке, т.е. в цикле вычисляются значения функции и выводятся на экран в виде: Y1= Y2= Y3= Y4= , и т.д.

тип входных данных: целое тип выходных данных: целое, функция: x1*sin(x2) + x3*sin(x4)

Опишите на рускком языке или в виде блок-схемы алгоритм решения обобщенного квадратного уранения: ах²+bх²+с=0 В обобщенном квадратном уравнении любой

из коэффициентов может равняться нулю(в том числе и все одновременно).

Распишите именно как сдавать,на чистовик,не что нужно делать,а именно как в задании.

Помогите пожалуйста, очень нужно!

Программирование
Решить квадратное уравнения вида ax^2 + bx + c = 0
К решению математическая модель:
Дано:
Нужно:
Связь:
При:



Вы находитесь на странице вопроса "Задан вид квадратного уравнения ах квадрат +bx+c=0, коэффициенты a,b,c. Найти корни уравнения x1,x2.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.