Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

написать програму для ПАСКАЛЬ на уравнение ах(в квадрате)+bx+c=0. нужна только программа, чтобы я ввела в ПАСКАЛЬ.

10-11 класс

Lotus 29 июля 2014 г., 16:57:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alferia
29 июля 2014 г., 19:26:41 (9 лет назад)

var a,b,c,x1,x2,D:real;
begin
Writeln('Введите коэффициенты квадратного уравнения');

Write('a = '); readln(a);
Write('b = '); readln(b);
Write('c = '); readln(c);
D:=b*b-4*a*c;
if D<0 then writeln('Действительных корней нет')
else
begin
x1:=(-b+sqrt(D))/(2*a);
x2:=(-b-sqrt(D))/(2*a);
Writeln('x1 = ',x1);
Writeln('x2 = ',x2);
readln
end;
end.

Ответить

Другие вопросы из категории

Читайте также

Добрый вечер, помогите мне!

Нужно написать код для программы Pascal ABC, нужно написать код для решения этого уравнения. Спасибо!

(код паскаль)Написать набор процедур для работы с обыкновенными дробями, обеспечив их сложение, вычитание, умножение, деление. Примечание: обыкновенную

дробь представлять двумя целыми числами: первое число представляет числитель дроби, а второе - знаменатель. В процессе вычислений требуется сокращать дроби на их наибольший общий делитель (НОД). Если одно из чисел равно нулю, то НОД берем равным 1. Разработать также отдельные процедуры для ввода (на экран выводится надпись: «Введите числитель и знаменатель обыкновенной дроби») и вывода обыкновенных дробей (a/b).

Написать программу для Паскаль

Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. Программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.

Решите ну ктонибуть уже устал ждать

Написать програму на языке паскаля с использование цикла с пердусловием для решении следущей задачи:

дано натуральное как минимум трёхзначное число.Определить,верно ли ,что удвоеная сумма друх его послеследних цифр меньше квадрата первой цифры.



Вы находитесь на странице вопроса "написать програму для ПАСКАЛЬ на уравнение ах(в квадрате)+bx+c=0. нужна только программа, чтобы я ввела в ПАСКАЛЬ.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.