Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пк запрашивает название и радиусы орбит двух планет (в миллионах км) и скорости движения орбит (в миллионах км в сутки). Вычислить продолжительность

10-11 класс

года на планетах (длина орбит/скорость). Результаты должны иметь вид:

Продолжительность года на планете <имя1> суток;

Продолжительность года на планете <имя2> суток;

Помогите составить программу в Pascal.

LestatDeLioncourt 11 нояб. 2013 г., 21:56:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Resurrectednastya
11 нояб. 2013 г., 23:57:08 (10 лет назад)

Program Planet;

var
R1, R2, l1, l2, v1, v2, time1, time2 : real;
c, b : string;

begin
Write('Планета1-');
Readln(b);
Write('Планета2-');
Readln(c);
Write('R1=');
Readln(R1);
Write('R2=');
Readln(R2);
Write('v1=');
Readln(v1);
Write('v2=');
Readln(v2);
L1:=2*Pi*R1;
L2:=2*Pi*R2;
Time1:=l1/v1;
Time2:=l2/v2;
Writeln('Продолжительность года на пленете ',b,'= ', Time1:0:2, ' суток');
Writeln('Продолжительность года на пленете ',c,'= ', Time2:0:2, ' суток');
end.

 

 

 

 

как-то так)

+ 0 -
799087
12 нояб. 2013 г., 1:27:42 (10 лет назад)

var

r1,r2,v1,v2:integer;

name1,name2:string;

begin

writeln ('Введите название двух планет');

readln (name1,name2);

writeln ('Введите радиусы двух планет');

readln (r1,r2);

writeln ('Введите скорости движения орбит');

readln (v1,v2);

writeln ('Продолжительность года на планате ',name1,'=', r1/v1);

writeln ('Продолжительность года на планате ',name2,'=', r2/v2);

end.

Ответить

Другие вопросы из категории

Сколько секунд потребуется модему , передающему информацию со скоростью 9600 бит\с,чтобы передать 70 страниц текста в 60 строк по 75 символов каждая при

условии, что каждый символ кодируется двумя байтами? Результат представьте целым числом. ( Служебной информацией пренебречь)

Даны натуральное число n, символы s1,...sn. , группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя ,

будем называть словами. подсчитать количество букв a в последнем слове данной последовательности

В TPascal

тема для сайта срочно
Пожалуйста, добавьте программу, которая заставит двигаться глаза:

uses graphABC;
begin
setwindowsize(500,400);
setpencolor(clwhite);
setbrushcolor(clbrown);
ellipse(60,40,100,90);
ellipse(160,40,200,90);
circle(130,110,70);
ellipse(90,110,170,160);
setbrushcolor(clwhite);
setpencolor(clblack);
circle(105,80,15);
circle(155,80,15);
setbrushcolor(clblack);
ellipse(100,75,110,93);
ellipse(150,75,160,93);
ellipse(150,75,160,93);
setpencolor(clwhite);
setbrushcolor(clbrown);
floodfill(60,40,cllightblue);
end.

Читайте также

Построить блок схему алгоритма и написать программу для решения: Даны действительные числа z,y,x.Если сумма двух чисел x y меньше единицы ,то каждое из

заданных трёх чисел заменить полусуммой двух других,в противном случае возвести в квадрат.

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию.

Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

Постройте алгоритм и составьте программу, по которой будет реализован следующий сценарий: компьютер запрашивает номер дня недели, после ввода компьютер

сообщает название этого дня. Например, если ввели 1, то выведется фраза "это понедельник" и т.д.

Составить программу, которая формирует файл записей, содержащих информацию об автомобиле (название модели, год выпуска, цена, цвет), а также найти в

массиве записей и вывести на экран названия моделей красного цвета, випускалиcя в 2000 году.

P.s Помогите пожалуйста, заране огромное спасибо.



Вы находитесь на странице вопроса "Пк запрашивает название и радиусы орбит двух планет (в миллионах км) и скорости движения орбит (в миллионах км в сутки). Вычислить продолжительность", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.