Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу, которая определяет код символа, предыдущий и последующий символы.

10-11 класс

Lerkasira 02 нояб. 2013 г., 21:24:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ТаригитаЙ
02 нояб. 2013 г., 22:11:59 (10 лет назад)

var
 ch:char;
begin
writeln('vvedite simvol');
readln(ch);
writeln('kod simvola ',ch,': ',ord(ch));
writeln('Pred: ',pred(ch));
writeln('Sled: ',succ(ch));
readln;
end.

Ответить

Другие вопросы из категории

Сколько секунд потребуется модему , передающему информацию со скоростью 9600 бит\с,чтобы передать 70 страниц текста в 60 строк по 75 символов каждая при

условии, что каждый символ кодируется двумя байтами? Результат представьте целым числом. ( Служебной информацией пренебречь)

Даны натуральное число n, символы s1,...sn. , группы символов, разделённые пробелами (одним или несколькими) и не содержащие пробелов внутри себя ,

будем называть словами. подсчитать количество букв a в последнем слове данной последовательности

В TPascal

тема для сайта срочно
Пожалуйста, добавьте программу, которая заставит двигаться глаза:

uses graphABC;
begin
setwindowsize(500,400);
setpencolor(clwhite);
setbrushcolor(clbrown);
ellipse(60,40,100,90);
ellipse(160,40,200,90);
circle(130,110,70);
ellipse(90,110,170,160);
setbrushcolor(clwhite);
setpencolor(clblack);
circle(105,80,15);
circle(155,80,15);
setbrushcolor(clblack);
ellipse(100,75,110,93);
ellipse(150,75,160,93);
ellipse(150,75,160,93);
setpencolor(clwhite);
setbrushcolor(clbrown);
floodfill(60,40,cllightblue);
end.

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа:

28 15 10

Наибольшее число: 28

2)Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее использования.

Пример:

Введите число:

100

Сумма = 500

Буду очень признателен за помощь.

Составьте программу, которая :

а) Определяет коды двух введённых с клавиатуры символов;
б)Выполняет операцию сцепления трёх введённых с клавиатуры символов;
на Pascal

помогите решить задачки по Паскалю "4": Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее

использования. Пример: Введите число: 100 сумма = 5050

"5":

Составить функцию, которая определяет, сколько зерен попросил положить на N-ую клетку изобретатель шахмат (на 1-ую – 1 зерно, на 2-ую – 2 зерна, на 3-ю – 4 зерна, …) Пример: Введите номер клетки: 28 На 28-ой клетке 134217728 зерен.

1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1. 2. составить программу, замены положительных

элементов настоящей таблице х [1 .. 10] на 0.

3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.

4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.



Вы находитесь на странице вопроса "Составьте программу, которая определяет код символа, предыдущий и последующий символы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.