Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста составить программу на языке Pascal! Даны три числа, написать программу, подсчитывающую количество чисел, равных нулю.

10-11 класс

Mosul 09 янв. 2014 г., 20:22:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Isaevaalen2014
09 янв. 2014 г., 21:28:40 (10 лет назад)

var 

  num, count:integer;

 

begin

    count:=0;

    for i:=1 to 3 do

    begin

        readln(num);

       if num=0 then count:=count+1

    end;

    writeln(count)

end.

+ 0 -
Baskoan
09 янв. 2014 г., 23:24:31 (10 лет назад)

Program Zadacha;

uses CRT;

var

a,b,c,kol:integer;

begin

Writeln('a=,b=,c=');

read(a,b,c);

kol:=0;

If a=0 then kol:=kol+1;

If b=0 then kol:=kol+1;

If c=0 then kol:=kol+1;

Writeln('Kolichestvo chisel ravnih nulu =',kol);

end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ НАЙТИ ОШИБКУ В РЕШЕНИИ!!!

Где начать цикл?
с клавиатуры вводится предложение, в котором слова разделены пробелами. определите, сколько слов в этом предложении начинается на букву "а".

Program Pr1;
var s, s1, s2:string;
count, n, i:integer;
begin
writeln('введите фразу');
readln(s);
count:=0;
for i:=1 to length(s) do
begin
n:=Pos(' ', s);
s1:=Copy(s,1,n-1);
s2:=Copy(s1,1,1);
if s2='а' then
count:=count+1;
Delete(s,1,1);
end;
writeln(count);
end.

Отметьте и последовательно соедените на координатной плоскости точки,координаты которых приведены в двоичной системеисчисления.Для этого надо заполнить

столбец перевода чисел в десятичный код.(числа мы уже нашли).

1)101 101 (45)

2)1000 1000(136)

3)1001 1000(152)

4)1011 110(94)

5)1100 110(102)

6)1100 111(103)

7)1011 111(95)

8)1011 10(46)

9)1001 10(38

10)1001 11(39)

11)1010 11(43)

12)1010 100(84)

13)111 100(60)

14)111 10(30)

15)101 10(22)

16)101 11(23)

17)110 11(27)

18)110 1001(105)

19)111 1001(121)

20)111 1000(120)

21)10 1000(40)

22)10 1001(41)

23)11 1001(57)

24)11 110(30)

25)100 101 (37)

Читайте также

ДАМ 22 ПУНКТА СРОЧНО

СОСТАВИТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ
данны два числа a и b.составить программу для вычисления среднего арифметического кубоы этих чисел

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Помогите, пожалуйста!!!

Составить программу на языке Турбо-Паскаль, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: Данные числа x, y являются координатами точки, лежащей в первой координатной четверти



Вы находитесь на странице вопроса "Помогите пожалуйста составить программу на языке Pascal! Даны три числа, написать программу, подсчитывающую количество чисел, равных нулю.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.