Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Заполните случайными числами в диапазоне от 1 до 5 два массива: A[1:20] и B[1:20]. Найдите и выведите на экран только те элементы этих массивов,

5-9 класс

значения которых совпадают. Например, если A[2]=B[2]=4, то на экран надо вывести: Номер: 2 значение: 4 Если совпадений нет, то вывести сообщение об этом. Заранее Спасибо.

Alyona174 25 февр. 2015 г., 20:23:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rozario
25 февр. 2015 г., 22:26:30 (9 лет назад)

const n = 20;
var
  a, b: array[1..n] of integer;
  i, count: integer;
begin
  for i := 1 to n do begin
    a[i] := 1 + random(5);
    b[i] := 1 + random(5);
    if(a[i] = b[i]) then begin
      writeln('Номер: ', i, ' Значение: ', a[i]);
      inc(count);
    end;
  end;
  if(count = 0) then writeln('Совпадений нет');
end.

Ответить

Другие вопросы из категории

Составить алгоритм нахождения площади и длины окружности если известен радиус.

Составить алгоритм нахождения площади и длины окружности если известен диаметр.

Как зашифровать слово калькулятор!?

Методом который изобрёл Юлий Цезарь. Кто знает, помогите зашифровать!!! Ато никак в голову не лезет!!!!!!

Задача на языке паскаль!

Определить принадлежит ли точка A(x) лежащая на координатной прямой отрезку [-3,3].

Читайте также

Составьте программу (в Pascal) "Угадай". Программа задумывает случайное число в диапазоне от 0 до 99.

Программа задумывает случайное число в диапазоне от 0 до 99. После каждой попытки играющего прога выводит сообщение "больше", "меньше", "угадано". Дается 10 попыток. Программа завершается, если дан правильный ответ или попытки закончились.

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "Заполните случайными числами в диапазоне от 1 до 5 два массива: A[1:20] и B[1:20]. Найдите и выведите на экран только те элементы этих массивов,", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.