Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

напишите плиз прогу срочно (на Паскале) которая из 2-хзначных чисел выводит такие, сума цифр которых одинакова. например: 12 и 21 и так далее

10-11 класс

NusyaBulatbekov 26 февр. 2016 г., 11:51:56 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89824660507
26 февр. 2016 г., 13:09:10 (8 лет назад)

Program Pr1;
uses crt;
var i,n,a,b:integer;
mas:array[10..99] of integer;
begin
for i:=10 to 99 do mas[i]:=i div 10+i mod 10;
for i:=10 to 98 do
for a:=i+1 to 99 do if mas[i]=mas[a] then writeln(a,' ',i);
end.

+ 0 -
90909090909099
26 февр. 2016 г., 13:44:35 (8 лет назад)

ghost22 как-то не понятно сделал прогу. Я по красивее и по-понятнее написал, вот:

uses crt;
var
i,j,n:integer;
begin
clrscr;
for j:=1 to 18 do begin
for i:=10 to 99 do begin
if (i mod 10)+(i div 10)=j then
write(i, ' ');
end;
writeln('');
end;
end.

Ответить

Другие вопросы из категории

Как в программе PascalABC.NET вывести символы

из таблицы ASCII?
Например, необходимо оформить вывод данных на экран в виде аккуратной таблицы. Как
описать в программе ввод этих символов: └

Автоматическое устройство осуществило перекодировку текстового сообщения на русском языке, первоначально записанного в Unicode, в кодировку

КОИ-8. При этом информационный объем сообщения уменьшился на 480 бит. Сколько символов в этом сообщении?

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

1) Вводится 4 числа. Вывести на экран наибольшую из первых цифр заданных чисел. Например, если a=46, b=831, c=2996, d=486, то напечатать число 8.

Использовать процедуру. - Написать на Паскале.

2) Дан массив A(10,5). Поменять местами элементы первого столбца с элементами столбца, в котором находится максимальный элемент массива. - Написать на Паскале.

3) Вводятся значения трех переменных. Переставить значения. Дополнительные переменные не использовать.
Составить алгоритм.



Вы находитесь на странице вопроса "напишите плиз прогу срочно (на Паскале) которая из 2-хзначных чисел выводит такие, сума цифр которых одинакова. например: 12 и 21 и так далее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.