Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1.Вводится номер месяца. Надо определить к какому сезону относится этот месяц

5-9 класс

2.Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей".

Написать программу в PascalABC

Icechery 26 окт. 2014 г., 6:44:36 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1999ангелина
26 окт. 2014 г., 8:57:48 (9 лет назад)

1)
var x:integer;
begin
read (x);
if (x=12) or (x=1) or (x=2) then writeln ('Зима');
 if (x=3) or (x=4) or (x=5) then writeln ('Весна'); 
 if (x=6) or (x=7) or (x=8) then writeln ('Лето'); 
 if (x=9) or (x=10) or (x=11) then writeln ('Осень'); 
end.
2)
var K,a:integer;
begin
readln(K);
a:=K mod 10;
if (K=11) or(K=12) or (K=13) or (K=14) then writeln ('У меня ',K,' друзей') else
begin
if (a=1) then writeln ('У меня ',K,' друг');
if (a=0) or ((a>=5) and (a<=9)) then writeln ('У меня ',K,' друзей');
if (a>=2) and (a<=4) then writeln ('У меня ',K,' друга');
end;
end.

Ответить

Читайте также

1.Вводится номер месяца. Надо определить к какому сезону относится этот месяц

2.Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей".

Решить в паскаль абс

Задание по информатике!!!

Помогите пожалуйста
Компьютерный вирус А заполняет 2 Гбайта за один месяц, вирус В заполняет 2 Гбайта за два месяца, вирус С заполняет 2 Гбайта за три месяца, вирус D заполняет 2 Гбайта за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса. Сколько Гбайтов они заполняют за один месяц?

Дайте пожалуйста условие и решение: 1. текст содержит 2048 символов, один символ кодируется 2 байтами. Каков объём сообщения в битах? 2. объём файла

хранящегося на диске 514 Кбайт, при форматировании диска размер кластера составил 8 Кбайт. Определите кол-во кластеров, которое потребуется для хранения данного файла на диске. 3. сколько цветов будет содержать палитра, если на один пиксель отводится 4 бита памяти? 4.для кодирования одного пикселя служит двоичный код 1000. сколько цветов можно закодировать в этом пикселе? 5. сколько битов памяти достаточно для кодирования одного пикселя 16-ти цветного изображения? 6. известно, что для хранения файла используется 31 кластер, размер кластера составляет 6 Кбайт, при этом последний кластер заполнен на половину. какой объём файла в килобайтах? 7. каков минимальный объём видеопамяти, необходимый для хранения графического изображения, занимающего область экрана 512 x 512 точек, где каждая точка может иметь один из 512 цветов? 8. Средняя скорость передачи данных по каналу связи равна 28800 бит/с. сколько секунд потребуется для передачи по этому каналу цветного изображения размером 640 x 480 пикселей, при условии, что цвет каждого пикселя кодируется 3 байтами. 9. на одной странице размещается 60 строк текста по 25 символов в строке. принтер печатает 6 страниц в минуту. за сколько секунд принтер напечатает 27000 символов? 10. определите к какой группе относятся действия: 1) редактирование 2) форматирование а) замена одного символа на другой; б) вставка пропущенного слова; в) изменение шрифта; г) удаление фрагмента текста; д) выравнивание текста по ширине; е) автоматическая проверка правописания; ж) изменение междустрочного расстояния; з) изменение размеров полей страницы; и) удаление ошибочного символа; к) поиск и замена; л) перемещение фрагмента текста. 11. укажите какие из примеров удовлетворяют маске: ?ese*ie.?t* 1) seseie.ttx 2) esenie.ttx 3) eseie.xt 4) sesenie.txt

Компьютерный вирус А заполняет 1 Гб памяти за один месяц, вирус В заполняет 1 Гб за два месяца, вирус С заполняет 1 Гб за три месяца, вирус D заполняет 1 г

б за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса. Через какое время на 1 Гб памяти не останется области, не заполненной вирусами? а) четверть месяца б) половина месяца в) один месяц г) два месяца

компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за три месяца, вирус D

заполняет 1 Гбайт за шесть месяцев. На компьютере одновременно обнаружены сразу все четыре вируса. Сколько гигабайтов они заполнят за один месяц?



Вы находитесь на странице вопроса "1.Вводится номер месяца. Надо определить к какому сезону относится этот месяц", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.