Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ПОМОГИТЕ ПОЖАЛУЙСТА!

5-9 класс

Задание
Переведите из десятичной системы счисление следующие числа:
0,025 → А(2 внизу рядом с А)
0,0625

ЛесенокПолшкова 11 окт. 2015 г., 16:25:34 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sashunka987
11 окт. 2015 г., 18:02:09 (8 лет назад)

Ну это не совсем  тривиальное действие

Если при переводе целых чисел мы при переводе из 10-й системы при переводе в другую делим на основание системы перевода , то с дробями мы совершаем обратные действия мы УМНОЖАЕМ  на основание системы счисления в которую переводим на 2 , 8 или 16, потом при произведении целая часть отбрасывается и переводится в цифру той сиситемы в которую переводим и сноваа умножаем дробную часть на основанине,до тех пор пока в дроби не получится 0 или так и будет бесконечная дробь

3. 0.0625 в 16 ричную сисстему

0.0625*16=1 целая часть 1 дробная 0 получаем что 0.0625 (10)=0.1 (16)

2. 0.0625 в 8 ричную

0.0625  * 8= 0.5 получается целая 0 дробная 5 - целую пишем как главную после запятой а 0.5 снова умножаем на 8 0.5*8=4 целая 4 дробная 0

0.0625 (10)=0.04 (8)

1. 0.025 в 2 чную

0.025*2=0.05 целая 0 дробная 05 снова дробную на 2 0.05*2= 0.1 целая 0 дробная 1 умножаем на 2 0.1*2= 0.2 целая 0 дробь 2 0.2*2=0.4 целая 0 дробь 4 0ю4*2=0.8 цлая 0 дробь 8 0.8*2=1.6 целая 1 дробь 6 0.6*2=1.2 целая 1 дробь 2 и получается что с этого места начинается периодическая дробь так как 0.2 мы уже раньше видели итак

0.025 (10)= 0.0000011001100110 ...... (2)= 0.0000(0110) (2)

Ответить

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Как пройти 7 уровень в час кода ам няма помогите пожалуйста!!

Как пройти 9 уровень в час кода ам няма помогите пожалуйста!!

Люди Люди Люди если вы читаете это сообщение значит вы просто обязаны помочь! пожалуйста если у вас есть паскаль помогите пожалуйста решить первое и

второе задание ну или хотя бы только первое .Это вопрос жизни и смерти помогите пожалуйста P.S задание во вложениях.заранее спасибо и знайте если вы поможете значит вы самый добрый и отзывчивый человечек!)



Вы находитесь на странице вопроса "ПОМОГИТЕ ПОЖАЛУЙСТА!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.