Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан двумерный массив размером n*n. Создать функцию которая находит факториал каждого элемента массива и заменяет исходный элемент на его

10-11 класс

факториал(значение функции). в первой строке написано число n.(4! =1*2*3*4)
3 2 24 5047
2 4 7 6 720 40320
3 6 8 2 24 120
2 4 5

Nigora223 09 апр. 2016 г., 11:59:17 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МашаГончарова
09 апр. 2016 г., 13:57:36 (8 лет назад)

Program Task;
Var a: Array [,] of LongInt;
i, j, n, b, c: Integer;
Begin
    Write('n = ');
    ReadLn(n);
    SetLength(a, n, n);
    For i := 0 To n - 1 Do
    Begin
        WriteLn('Введите ', i + 1, ' рядок массива (', n, ' чисел) через пробел');
        For j := 0 To n - 1 Do
        Begin
            Read(a[i, j]);
            b := a[i, j];
            c := 1;
            While b > 0 Do
            Begin
                c := c * b;
                b := b - 1;
            End;
            a[i, j] := c;
        End;
    End;
    WriteLn('Результат:');
    For i := 0 To n - 1 Do
    Begin
        For j := 0 To n - 1 Do
            Write(a[i, j], ' ');
        WriteLn;
    End;
    ReadLn;
End.

Ответить

Читайте также

дана программа нахождения суммы всех элементов массива. Изменить программу таким образом,чтобы:

a) массив состоял из 15 элементов вещественного типа;
b) значения элементов массива должны меняться в интервале от 0 до 5;
c) в результате выполнения программы должно быть найдено произведение всех элементов массива, а не их сумма

Program massiv;
const n=10;
Var a: array [1..n] of integer;
s,i integer;
Begin
writeln (‘ исходный массив.‘);
For i:= 1 to n do
begin
a [ i] := random (10);
write (‘a[‘i'] =', a[i], '');
end;
s:=0;
For i:= 1 to n do
s:= s+a[i];
Writeln (‘ сумма всех элементов массива S=‘, s);
end.

С++

одномерный массив из 15 элементов нужно посчитать сумму положительных элементов массива и произведение отрицательных элементов и узнать что больше сумма или произведение

Дан двумерный массив a размером n*n. Написать программу определения номера столбца с максимальной суммой элементов. Дан двумерный массив

а размером n*n. В каждой строке изменить значения элементов, стоящих за минимальным элементом этой строки, на 1



Вы находитесь на странице вопроса "Дан двумерный массив размером n*n. Создать функцию которая находит факториал каждого элемента массива и заменяет исходный элемент на его", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.