Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел. нужно к

10-11 класс

этой задачке составить блок-схему. пожалуйста. дам 60 баллов

Дарьяша26 04 февр. 2014 г., 1:14:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настёнчек
04 февр. 2014 г., 3:11:01 (10 лет назад)

var
 i:integer; 
 a,sum,s:real; 
begin   
for i:=1 to 10 do     
   begin         
    read(a);
    sum:=sum+a;     
   end;   
 write('Сумма: ',sum);   
 s:=s/10;     
write('Cреднее арифметическое: ',s);
 end.

+ 0 -
Ник6576
04 февр. 2014 г., 4:31:13 (10 лет назад)

var i:integer;
sum,sr,n:real;
begin
sum:=0;
for i:=1 to 10 do
begin
read(n);
sum:=sum+n;
end;
sr:=sum/10;
write('sum=', sum, 'sred=', sr);
end.

Ответить

Другие вопросы из категории

После установки Win2000 необходимо создать учетную запись. Какую программу требуется использовать для этого?

1) User Manager for Domain

2) Computer Management

3) User Manager

4) Active Directory Users and Computers

Читайте также

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

(1) вариант

1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > 28 и их среднее арифметическое
2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные
3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол-во и сумму положительно ввёдных чисел

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.



Вы находитесь на странице вопроса "Написать программу, которая вводит с клавиатуры последовательность из 10 вещественных чисел, считает сумму и среднее арифметическое этих чисел. нужно к", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.