Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать алгоритм вычисления по формуле: y = (1-x2+2.5x3+x4)2 учитывая следующие ограничения: 1) пользоваться можно операциями сложения, вычитания и

5-9 класс

умножения; 2) каждое выражение может содержать только одну арифметическую операцию

UIhB22 21 сент. 2013 г., 23:33:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rdcvft
22 сент. 2013 г., 1:07:04 (10 лет назад)

var y,x:real;

begin

readln(x);

y:=2*(1-x*x+2.5*x*x*x+x*x*x*x);

writeln(x);

end.

 

var x,y,z:real;

begin

readln(x);

y:=-x*x;

z:=y*x;

z:=2.5*z;

y:=y+z;

z:=z*x;

y:=y+z;

y:=y+1;

y:=y*2;

writeln(y);

end.

Ответить

Другие вопросы из категории

К.р!!! помогите)))

Нужно решить 2 номер и ещё если можно 3. Желательно в письменном виде. Заранее спасибо.

1.Напишите программу вычисления веса идеального мужчины по формуле:

Ид.Вес-Рост в см -100
Значение роста вводится с клавиатуры. Результат вывести в следующем виде:
Для мужчины ростом 165 см идеальный вес равен 65 кг.
2.По аналогии с заданием №1 составить программу, определяющую идеальный вес женщины по следующей формуле:
Ид.Вес=Рост в см - 100 -10% (от Рост в см - 100)

1, С клавиатуры вводятся 10 натуральных чисел. Вычислить сумму четных элементов.

2, С клавиатуры вводятся 15 натуральных чисел. Подсчитать количество элементов, кратных 3 и 5.
3, С клавиатуры вводятся 10 натуральных чисел. Вычислить произведение чисел, больших 10, но меньших 20.

Перевести числа

а) 333^4 в 10 ичную
б) 1100111^2 в 10 ичную
в)А13В^16 в 10 ичную


Перевести числа из 10ичной системы
а) 16125 в 3ичную
б)131 в 2ичную
в)2563 в 8 ичную
г) 125683 в 16тиричную

Читайте также

Написать алгоритм вычисления по формуле y=(1-x²+2,5³x+x)² третий x в четвертой степени. не нашел маленькой четверки. Учитывая ограничения 1) Пользоваться

можно только сложением,вычитанием,и умножением 2) каждое выражение может содержать только 1 арифметическую операцию.

напишите на АЯ алгоритм вычисления y по формуле ,где x-заданное число.Учтите следующие ограничения:1)в арифметических выражениях можно использовать только

опереции сложения,вычитания,и умножения;2)каждое выражение может содержать только одну арифметическую операцию.Выполните трассировку алгоритма при x=2

1) Как вы думаете, можно ли использовать в арифметическом выражении оператора присваивания неопределенную переменную? К каким последствиям это может

привести?

2) Напишите на АЯ алгоритм сложения двух простых дробей(без сокращения дроби)

3) Напишите на АЯ алгоритм вычисления Y по формуле: y=(1-x2+5x^4)^2, где x- заданное целое число. Учтите следующие ограничения: 1) В арифметических выражениях можно использовать только операции сложения, вычитания и умножения. 2) Выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при x=2.

4) Пользуясь ограничениями предыдущей задачи, напишите наиболее короткие алгоритмы вычисления выражений: y=x^8, y=x^10, y=x^15, y=x^19. Выполните трассировку алгоритмов.

5) Запишите алгоритм циклического обмена значениями трех переменных A,B,C. Схема циклического обмена:

a-->b-->c(стрелочка C к A сверху)

Например, если до обмена было: A=1,B=2,C=3, то после обмена должно стать: A=3,B=1,C=2. Выполните трассировку.



Вы находитесь на странице вопроса "Написать алгоритм вычисления по формуле: y = (1-x2+2.5x3+x4)2 учитывая следующие ограничения: 1) пользоваться можно операциями сложения, вычитания и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.