Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите,пожалуйста))напишите блок-схему к этой программе(одномерные массивы)язык программирования-Паскаль.

5-9 класс

Программа:
var a, b:array [1..15] of integer;
i, max, min, j1, j2, sum, k:integer;

begin
write('Измерения ростов всех студентов ');
randomize;
for i:=1 to 15 do
begin
a[i]:=random(50)+140;
write ('а[',i,']-',a[i],';');
end;
writeln;
write('Рост самого высокого студента (номер): ');
max := 0;
min := 65535;
k := 0;
sum := 0;
for i := 1 to 15 do
begin
if (a[i] > max) then begin max := a[i]; j1 := i; end;
if (a[i] < min) then begin min := a[i]; j2 := i; end;
sum := sum + a[i];
if (a[i] > 170) then
begin
inc(k);
b[k] := a[i];
end;
end;
writeln(j1);
write('Рост самого низкого студента (номер): ');
writeln(j2);
write('Средний рост: ');
writeln(sum/15:4:2);
write('Массив b:');
for i := 1 to k do write('B[',i,']',b[i], ';');
readln;
end.
Вывод:
Измерения
ростов всех студентов
а[1]-159;а[2]-183;а[3]-176;а[4]-168;а[5]-156;а[6]-165;а[7]-187;а[8]-144;а[9]-162;а[10]-164;а[11]-142;а[12]-158;а[13]-159;а[14]-163;а[15]-182;
Рост самого высокого студента (номер): 7
Рост самого низкого студента (номер): 11
Средний рост: 164.53
Массив b:B[1]183;B[2]176;B[3]187;B[4]182;
буду очень благодарна))

Asmikmartirosya 01 мая 2014 г., 18:18:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annaprokofeva
01 мая 2014 г., 19:21:02 (9 лет назад)

Блок-схема во вложении.

Ответить

Другие вопросы из категории

Помогите пожалуйста!

Современный монитор позволяет получать на экране 16 777 216 различных цветов.Сколько битов памяти занимает 1 пиксель?

Читайте также

ребят, помогите пожалуйста, ну ооочень нужно, от этого зависит аттестуют меня или нет, заданий правда много, и пожалуйста, не пишите херню либо очень

мало
эти задания нужно сделать циклами while и for, т е чтобы получилось 12 программ

1. Составьте программу вычисления значения функции: y=7x^2+1/x^2-16
2. Составьте блок-схему алгоритма и программу расположения четырех чисел в порядке возрастания.
3*. Составьте программу, определяющую вид треугольника по трем его сторонам A, B, C.

4. Составьте блок-схему алгоритма и программу вывода на экран всех трехзначных чисел, кратных 7.
5. Составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел, кратных 13.
6*. Составьте программу вывода на экран таблицы степеней 2ⁿ, где 0 ≤ n ≤ 10.

я вас просто умоляю, напишите, пожалуйста

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

ПОМОГИТЕ ПОЖАЛУЙСТА!!!

Даны 2 числа.Найти их сумму,если числа равны,и найти их произведение,если числа не равны.Написать блок схему и составить программу на Паскаль.



Вы находитесь на странице вопроса "помогите,пожалуйста))напишите блок-схему к этой программе(одномерные массивы)язык программирования-Паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.