Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу на Pascal, попадает ли точка с заданными координатами в область?

10-11 класс

Soffa090802 20 июля 2015 г., 17:02:17 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ilmirarz
20 июля 2015 г., 19:19:23 (8 лет назад)

program task2;
var R, x, y : real;
begin
    writeln('Введите значения R, x, y:');
    read(R, x, y);
    if (((x >= 0) and (y >= 0) and (x * x + y * y <= R * R)) or ((x < 0) and (y < 0) and (y >= -x - R))) then
        writeln('Точка с координатами x: ', x, ', y: ', y, ' принадлежит заданной области.')
    else
        writeln('Точка с координатами x: ', x, ', y: ', y, ' не принадлежит заданной области.');
end.

Ответить

Другие вопросы из категории

СДЕЛАЙТЕ БЛОК-СХЕМУ И НАПИШИТЕ ПРОГРАММУ ДЛЯ ДАННОЙ ЗАДАЧИ:

Ввести с клавиатуры массив из 5 элементов, найти минимальный из них.

(код паскаль)Написать набор процедур для работы с обыкновенными дробями, обеспечив их сложение, вычитание, умножение, деление. Примечание: обыкновенную

дробь представлять двумя целыми числами: первое число представляет числитель дроби, а второе - знаменатель. В процессе вычислений требуется сокращать дроби на их наибольший общий делитель (НОД). Если одно из чисел равно нулю, то НОД берем равным 1. Разработать также отдельные процедуры для ввода (на экран выводится надпись: «Введите числитель и знаменатель обыкновенной дроби») и вывода обыкновенных дробей (a/b).

Читайте также

Написать программу на Pascal

определить попадает ли точка A(x,y) внутрь треугольника, углы которого заданы координатами (0,2), (-2,0), (2,0)

написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,

которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от
того, лежит ли точка внутри заштрихованной области, вне заштрихованной области
или на ее границе.



Вы находитесь на странице вопроса "Написать программу на Pascal, попадает ли точка с заданными координатами в область?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.