Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить в паскале.Оценки, полученные спортсменом в соревнованиях по фигурному катанию (в баллах) хранятся в массиве из 18 элементов. В первых 6

5-9 класс

-ти элементах записаны оценки по обязательной программе, с 7-го элемента по 12-ый записаны оценки по короткой программе, в остальных по произвольной программе. Выяснить, по какому виду программы спортсмен показал лучший результат. это одномерный массив

Cemeizog 14 нояб. 2016 г., 11:08:55 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastena0330
14 нояб. 2016 г., 12:39:44 (7 лет назад)

{Pascal ABC.NET}

var a:array[1..18] of integer;

s1,s2,s3:string;

i,max1,max2,max3:integer;

begin

max1:=0;

max2:=0;

max3:=0;

s1:='Обязательная:';

s2:='Короткая:';

s3:='Произвольная:';

for i:=1 to 18 do

readln(a[i]);

for i:=1 to 18 do

begin

if (i<=6) and (a[i]>max1) then max1:=a[i];

if (i>6) and (i<=12) and (a[i]>max2) then max2:=a[i];

if (i>12) and (a[i]>max3) then max3:=a[i];

 end; writeln(s1+max1); writeln(s2+max2); writeln(s3+max3); end. 

Ответить

Читайте также

ПОМОГИТЕ!!!удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.если таких элементов несколько ,

удалить последний из найденных.Помогите решить в паскале.(вычислить средн.ариф.номер э-та,....)

Составить программу

оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок. составьте программу, которая определяет зачетную оценку спортсмена. оценки судей ввести в клавиатуры (целые числа от 1 до 6)

PASCAL. нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если рОЧЕНЬ нужна помощь. ПОЖАЛУЙСТА помогите решить задачу в PASCAL (если решиш - проси

что угодно, помогу)Вот задача - Под конец учебного года ученики 11 класса решали понять у кого же из них будет самый высокий средний балл ? Известно , что - в классе учится 14 учеников, - Сумма всех средних баллов аттестата = 100.Известно также , что первый ученик имел средний балл, который составляет 1/ 12 суммы всех средних баллов. Второй ученик - на 0,15 % больше, чем первый ученик , но на 1,75 % меньше , чем третий ученик . Средние баллы аттестатов двух сестер были равными среднему арефметичному оценок вышеупомянутых учеников , разделенном на 1.5 . Четвертый ученика на конец года имел такой же балл , как и первый ученик , но на 5% меньше , а остальные ученики - имели равные баллы .Какой средний балл на конец года получил каждЫй?

Помогите решить задачи с помощью Паскаля:

1. В массиве все отрицательные элементы переместить в начало массива, а остальные в конец с сохранением порядка следования.
2. Дана последовательность целых чисел, среди чисел есть одинаковые, создать массив различных чисел последовательности и полученный массив отсортировать по возрастанию.

помогите решить в Паскале


Вы находитесь на странице вопроса "Помогите решить в паскале.Оценки, полученные спортсменом в соревнованиях по фигурному катанию (в баллах) хранятся в массиве из 18 элементов. В первых 6", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.