Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько потребуется плиток

5-9 класс

для укладки пола размером MxN, если резать плитку на части Чиполлино не умеет.
Входные данные: MxN - целые числа, размер пола.
Выходные данные: Целое число - кол-во плиток.

Sozvuchnaya 26 марта 2014 г., 19:28:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mironovmishg
26 марта 2014 г., 20:10:27 (10 лет назад)

program gt1;
label 3,9;
var m,n,q,r,w,z,t:longint;
begin
read(m,n);
w:=m;
t:=n;
3:
q:=m div n;
r:=m mod n;
if (r=0)then goto 9;
m:=n;
n:=r;
goto 3;
9:
z:=(w div n)*(t div n);
write(z);
end.

+ 0 -
Chernyxirina
26 марта 2014 г., 21:25:17 (10 лет назад)

VB.

Dim m,n as integer
m=InputBox("Введите m")
n=InputBox("Введите n")

MsgBox("Количество необходимых плиток - " & m*n)

+ 0 -
20aika02
26 марта 2014 г., 23:03:52 (10 лет назад)

а пример можеш написать?

+ 0 -
ВЮС
26 марта 2014 г., 23:34:16 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

Переведите пожалуйста.

2048 байт в кбит
3 кбит в байт
1536 байт в кбит

Для групповых операций с файлами используются маски имён файлов. Маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов

символов, в которых также могут встречаться следующие символы: "?" - означает ровно один произвольный символ; "*" - означает любую последовательность символов произвольной длины, в том числе и пустую последовательность. В каталоге находится 6 файлов: fedot.xls msdos.xlsx london.xls fedot.xml odor.xlsx sdoba.xls Определите по какой из масок из них будет отобрана указанная группа файлов: fedot.xls msdos.xlsx odor.xlsx london.xls 1) ?do*.xls 2) ?*do?.xls* 3) *do*.xls* 4) ?do?.xls
ПОЛНОЕ РЕШЕНИЕ,ЗАРАНЕЕ СПАСИБО

Напишите программу для угадывания слова. Она должна запрашивать от

пользователя строки, пока тот не введет слово, предусмотренное в программе.
Помогите,пожалуйста

СРОЧНО!!! СРОЧНО!!! СРОЧНО!!! ПОМОГИТЕ, ПОЖАЛУЙСТА!!

Сегодня у Пети и Коли новая игра: Коля задумывает правило преобразования числовой информации. Задача Пети — отгадать это правило. Ниже приведены вопросы Пети и ответы Коли в нескольких таких играх. Попробуйте отгадать, какое правило задумал Коля в каждой игре. Вопросы и ответы Правило преобразования
1→ 2; 2→3; 3→4; 10→11; 100→101
1→2; 2→4; 3→6; 4→8; 10→20; 100→200
1→3; 2→5; 3→7; 4→9; 10→21; 100→201
1→2; 2→1; 3→4; 4→3; 10→9; 11→12; 100→99
1→2; 2→1; 3→6; 4→2; 10→5; 11→22; 100→50
1→1; 2→1; 3→1; 4→1; 10→2; 11→2; 100→3
1→1; 2→2; 3→0; 4→1; 20→2; 21→ 0
1→0; 2→0; 3→1; 4→1; 20→6; 21→7

Читайте также

Бригаде строителей поручили уложить квадратной плиткой пол на кухне в виде шахматного узора. Но строители работали не очень слаженно, и когда весь пол

уже был уложен, оказалось, что в некоторых местах плитки одинакового цвета граничат друг с другом.

По заданному замощению определите, какое минимальное число строителей могло укладывать плитку.

Входные данные

Входной файл INPUT.TXT содержит восемь строк, состоящих из восьми символов W и B – полученное замощение. Символ W обозначает плитку белого цвета, а символ B – чёрную.

Выходные данные

В выходной файл OUTPUT.TXT нужно вывести одно число - искомое число строителей.

Помогитеееее

Бригаде строителей поручили уложить квадратной плиткой пол на кухне в
виде шахматного узора. Но строители работали не очень слаженно, и когда
весь пол уже был уложен, оказалось, что в некоторых местах плитки
одинакового цвета граничат друг с другом.


По заданному замощению определите, какое минимальное число строителей могло укладывать плитку.


Входные данные


Входной файл INPUT.TXT содержит восемь строк, состоящих из восьми
символов W и B – полученное замощение. Символ W обозначает плитку белого
цвета, а символ B – чёрную.


Выходные данные


В выходной файл OUTPUT.TXT нужно вывести одно число - искомое число строителей.


Примеры


№INPUT.TXTOUTPUT.TXT

Прошу, помогите! Задачи на тему - линейные алгоритмы. 1)От станции до озера S км.Туристы, направляясь от станции к озеру, полтора часа шли пешком со

скоростью А км/ч, а затем сели на попутную машину, которая ехала со скоростью В км/ч. За какое время туристы добрались до озера? 2)В школьном коридоре длиной 56 м нужно выкрасить пол. Выкрасив часть коридора длиной 22 м, израсходовали А кг краски. Сколько ещё нужно краски, чтобы докрасить пол? 3)Чтобы сварить 4 порции пшенной каши, нужно взять 220 г пшена, 1 л молока и зо г сахара. Сколько потребуется этих продуктов, чтобы сварить N порций каши? Плиииз помогите. Меня на этой теме не было и ничего не понимаю!

Мини-проект 2 («Kv_uravn»).

Создайте проект для расчёта корней квадратного уравнения. Продумайте названия
текстовых полей, чтобы не запутаться при программировании. Чтобы поставить
«квадрат» для икса, просто используйте ещё одну метку (Label). При нажатии на кнопку
«Рассчитать» вычисляется дискриминант, и, если он меньше нуля, то сразу
выдаётся сообщение «Корней нет» (через MsgBox), если равен нулю, то рассчитывается только значение X1, а если больше нуля – то X1 и X2. Рассчитанные значения корней должны
появиться в соответствующих текстовых полях на форме. Пример вида формы показан
на рисунке:



Вы находитесь на странице вопроса "Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько потребуется плиток", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.