Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу вычисляющую сумму членов массива, крест на крест, массив сложный, задается пользователем, каждый раз может меняться.

10-11 класс

Littleapple 04 сент. 2014 г., 23:59:24 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Золански
05 сент. 2014 г., 2:56:41 (9 лет назад)

const n=3;
var a:array[1..n,1..n] of integer;
i,j,sg,sp,s:integer;
begin
for i:=1 to n do
for j:=1 to n do a[i,j]:=random(20);
for i:=1 to n do begin
for j:=1 to n do write(a[i,j]:5);
writeln;
end;
sg:=0; sp:=0; s:=0;
for i:=1 to n do
for j:=1 to n do
if (i=j) then sg:=sg+a[i,j];
for i:=1 to n do
sp:=sp+a[i,n-i+1];
write('сумма элементов главной диагонали ',sg,' сумма элементов побочной диагонали ',sp);
 writeln;
if n mod 2=0 then s:=sg+sp
else s:=sg+sp - a[(n div 2)+1,(n div 2)+1];
write(' искомая сумма ',s);
writeln;
end.

+ 0 -
Aneshka
05 сент. 2014 г., 5:49:18 (9 лет назад)

из какой сферы вопрос?

+ 0 -
ктгмжмше
05 сент. 2014 г., 6:50:05 (9 лет назад)

информатика, программирование, фри паскаль

+ 0 -
Vitia81
05 сент. 2014 г., 8:02:00 (9 лет назад)

Программа ниже в комментариях.

Ответить

Другие вопросы из категории

Одна кодировочная таблица содержит 1024 символа. Для кодирования символа из второй таблицы требуется на 1 бит меньше, чем для кодирования символа из

первой таблицы. Определите, сколько символов включено во вторую кодировочную таблицу

Для приближенного перевода дат с мусульманского календаря на григорианский можно пользоваться следующей формулой: Г = М + 622 - (М/33) где Г - год

григорианского календаря, М - год мусульманского календаря.Какой год был по мусульманскому календарю в 1985 году (год начала изучения информатики в школах России)?
1) 1363-1364; 2) 1405-1406; 3) 2005-2006; 4) 2045-2046.

Информационный объем сообщения в 16 битной кодировке Unicode составляет 64 кбайта. на сколько можно увеличить длину исходного сообщения при

перекодировке его в международную систему кодов ASCII, сохраняя первоначальный информационный объем сообщения?

помогите решить пожалуйста
Помогите нужен линейный алгоритм на паскале. Составить алгоритм для решения задачи: Книга стоит d

руб., журнал h руб. У покупателя денег S руб. Хватит ли их на 3 журнала и 2
книги?.

Читайте также

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

1. написать программу, вычисляющую значение функции y=x-24

2. написать программу, вычисляющую значение функции (y=f(x))
y=x-2, если x>0,
y=0, если x=0,
y=x*x, если x<0

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99



Вы находитесь на странице вопроса "Написать программу вычисляющую сумму членов массива, крест на крест, массив сложный, задается пользователем, каждый раз может меняться.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.