Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти сумму и количество элементов одномерного массива значение которых >7 если таких элементов нет выдать ответ

5-9 класс

Milks2407 14 сент. 2014 г., 18:35:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Leemee
14 сент. 2014 г., 19:22:32 (9 лет назад)

#include <iostream>
#include <vector>
#include<windows.h>
using namespace std;
char bufRus[256];

char* Rus(const char* text) {

CharToOem(text, bufRus);
return bufRus;
}

int main()
{
vector<int> m;//объявили динамический массив
int n,count,sum;
count=sum=0;
cout<<Rus("Введите количество элементов массива:");

cin>>n;
for(int i=0;i<n;i++)
{ cout<<"m["<<i+1<<"]";
int temp;
cin>>temp;
if (temp>7){count++;sum+=temp;}
m.push_back(temp);
}
cout<<Rus("Количество элементов: ")<<count<<endl;
cout<<Rus("Сумма элементов: ")<<sum;
cin>>n;
return 0;
}

 

Как видите, всё просто)

Ответить

Другие вопросы из категории

ПОМОГИТЕ! МАТЕРИАЛА ВООБЩЕ НЕ ЗНАЮ, выдали тесты, а я не пойму:с 25 БАЛОВ!

Как называется конечная последовательность шагов в решении задачи, приводящая от исходных данных требуемому результату?

Компьютерный вирус А заполняет 1 Гбайт за один месяц, вирус В заполняет 1 Гбайт за два месяца, вирус С заполняет 1 Гбайт за шесть месяцев. На

компьютере одновременно обнаружены сразу все четыре вируса. Сколько гигабайтов они заполнят за один месяц???

Читайте также

Поиск результатов по фразе "заполните случайными числами диапозоне от 1 до 5 два массива : массивов, значения которых совпадают.Например , если

A[2]=B[2]=4, то на экран надо вывести: Номер:2 значение:4 Если таких совпадений нет то выведите на экран сообщение об этом."

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.



Вы находитесь на странице вопроса "Найти сумму и количество элементов одномерного массива значение которых &gt;7 если таких элементов нет выдать ответ", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.