Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задали очень сложну ззадачу по паскалю!!

5-9 класс

Составим программу "КАЛЬКУЛЯТОР", которая после ввода двух чисел и одного из знаков +, -, *, / произведёт вычисления, а результат выдаст на экран.


Натусик2001 17 нояб. 2014 г., 22:07:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gosha04
18 нояб. 2014 г., 0:44:52 (9 лет назад)

var
a,b,s:real;
sim:char;
Begin
writeln('Введите два числа');
readln(a,b);
writeln('Введите знак операции');
readln(sim);
case sim of
'+': s:=a+b;
'-': s:=a-b;
'*','x': s:=a*b;
'/',':': s:=a/b;
end;
writeln (a,sim,b,'=',s);
end.

+ 0 -
683
18 нояб. 2014 г., 2:00:24 (9 лет назад)

var
a,b:integer;
c:string;
begin
readln(a,b);
readln(c);
if c='+' then
writeln(a+b);
if c='*' then
writeln(a*b);
if c='-' then
writeln(a-b);
end.

так проще

Ответить

Читайте также

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i

надо решить задачу по паскалю) "Чтобы избавиться от простуды необходимо 20 таблеток колдрекса или 30 таблеток аспирина. Сколько порций эскимо можно

купить на эти деньги?"
напишите пожалуйста как составить это в паскале) буду благодарна:)



Вы находитесь на странице вопроса "Задали очень сложну ззадачу по паскалю!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.