Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Составить 5 любых алгоритмов

5-9 класс

Byguruslan 13 мая 2013 г., 23:15:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
I7arabellum
14 мая 2013 г., 0:02:18 (10 лет назад)

Напечатать сумму двух чисел:
VAR
   a, b: Real;
BEGIN
   Read(a, b);
   Write(a, b);
END.

Вывести расстояние между двумя точками:
VAR
   x1, x2, y1, y2: Real;
BEGIN
   Read(x1, y1);
   Read(x2, y2);

   Write(Sqrt(Sqr(x2 - x1) + Sqr(y2 - y1)));
END.

Возвести число N в K степень:
VAR
   n, k, ans, i: LongInt;
BEGIN
   Read(n, k);
   ans := 1;
   for i := 1 to k do
      ans := ans * n;
   Write(ans);
END.

Посчитать факториал числа N:
VAR
   ans: Int64;
   n, i: Integer;
BEGIN
   Read(n);
   ans := 1;
   For i := 2 to n do
      ans := ans * i;
   Write(ans);
END.

Вывести N-ое число Фибоначчи:
VAR
   n, i, f1, f2, f3: LongInt;
BEGIN
   Read(n);
   f3 := 1;
   for i := 1 to n do begin
      f1 := f2; f2 := f3;
      f3 := f1 + f2; end;
   Write(f3);
END.

Ответить

Другие вопросы из категории

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать произвольные целые значения. Опишите на русском языке или на одном из языков

программирования алгоритм, который находит и выводит номера двух элементов массива, наименее отличающихся друг от друга. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них. const N=30; var a: array [1..N] of integer; i, j, min, min2, s: integer; begin for i:=1 to N do readln(a[i]);

Читайте также

Умоляю помогите,мне нужно составить Алгоритм своего имени ,зовут меня Нурлан

Мне необходимо составить алгоритм каждой буквы : н,у,р,л,а,н
Примерно алгоритм выглядит вот так- Поднять перо. Сместиться в точку.Опустить перо.Сместиться на вектор.
Составьте хотя бы алгоритм буквы Н

. Система команд исполнителя Вычислитель состоит из двух команд: 1 – прибавить 2 2 – умножить на 3. а) Составьте для Вычислителя алгоритм получения из

числа 2 числа 30. Алгоритм должен включать только команды 1 и 2, и состоять не более чем из 4 команд.

Помогите пожаааалуйста ;-( ;-(

1) Приведите пример циклического алгоритма:а) из литературного произведенияб)из любой предметной области изучаемой в школе.
2) Ежегодный прирост рыбы в пруду составляет 15%. Запасы рыбы оценены в А тонн. Ежегодный план отлова В тонн. Наименьший запас рыбы составляет С тонн (запас ниже С тонн уже не восстанавливается) .Составьте БЛОК СХЕМУ алгоритма для подсчета кол-ва лет, в течение которых можно выдерживать заданный план.

1. Составьте блок-схему алгоритма и программу вычисления площади треугольника по трем сторонам. 2. Составьте программу вычисления объема, площади полной

поверхности, суммы ребер прямоугольного параллелепипеда. 3. Составьте программу вычисления диагоналей ромба по стороне и углу.



Вы находитесь на странице вопроса "Составить 5 любых алгоритмов", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.