Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 981 ответов!

Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием». Найти сумму и произведение первых n натуральных чисел.

10-11 класс

Nyushonok2002 02 окт. 2016 г., 18:06:23 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Daria1604
02 окт. 2016 г., 20:39:44 (7 лет назад)

program cikli;

unit math;

var

  i,n,s,p:integer;

  a:array[1..20]of integer;

begin

 writeln('Исходный массив: ');

 for i:=1 to 20 do begin

  a[i]:=RandomRange(1,20);

  writeln(' Элемент ',i,' =  ',a[i]);

 end;

 writeln('Сумму и произведения скольки первых чисел вы хотите посчитать? ');

 readln(n);

 s:=0;p:=1;

//цикл с параметром

 For i:=1 to n do begin

  s:=s+a[i];

  p:=p*a[i];

 end;

writeln('Цикл с параметром');

writeln('Сумма первых ',n,' чисел = ',s);

writeln('Произведения первых ',n,'чисел = ',p);

 

//цикл с предусловием

i:=1;p:=1;s:=0;

while i<>n do begin

 s:=s+a[i];

 p:=p*a[i];

 i:=i+1;

end;

writeln('Цикл с предусловием');

writeln('Сумма первых ',n,' чисел = ',s);

writeln('Произведения первых ',n,'чисел = ',p);

 

//цикл с постусловием

i:=0;s:=0;p:=1;

repeat

  i:=i+1;

  s:=s+a[i];

  p:=p*a[i];

until i=n;

writeln('Цикл с постусловием');

writeln('Сумма первых ',n,' чисел = ',s);

writeln('Произведения первых ',n,'чисел = ',p);

End.

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА ПОМОГИТЕ

Дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не превосходящие 10000. Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве. если таких чисел нет, нужно вывести сообщение «Таких чисел нет».

const N=30;

var a: array [1..N] of integer;

i, j, min: integer;

очень срочно надо,задание 5 под буквами В и Г .не могу разобраться.

заранее огромное спасибо!

Читайте также

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

Около стены наклонно стоит палка длиной x м. Один ее конец находится на расстоянии y м от стены. Определить значение угла между палкой и полом для

значений x=k м и y, изменяющегося от 2 до 3 метров с шагом h м. (решить в паскале ,цикл с параметром.Помогите )

Задача на pascal abc,решить задачу используя type Помогите пожалуйста очень надо) Составить программу которая создает

файл каждая строка которого выглядет так: табельный номер,фио,оклад.

ввести в файл данные о 5-ти работниках и вывести в другой файл максимальный оклад



Вы находитесь на странице вопроса "Решить задачу, используя «цикл с параметром», «цикл с предусловием», «цикл с постусловием». Найти сумму и произведение первых n натуральных чисел.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.