Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Проверить, является ли введенное

5-9 класс

слово палиндромом (перевертышем, то есть одинаково читается слева направо и
наоборот).
Пример палиндрома: КАЗАК.

Daidarasasha 16 мая 2013 г., 0:03:12 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natbabrina
16 мая 2013 г., 2:50:33 (11 лет назад)

1)
var s:string;
     i:integer;
     f:boolean;
begin
  f:=false;
  write ('S = ');
  readln(s);
  for i:=1 to length(s) div 2 do
   if s[i]=s[length(s)-i+1] then f:=true else 
    begin
      f:=false;
      break;
    end;
  if f then writeln ('PALINDROM') else writeln ('NOT PALINDROM');
  readln;
end.

2)
var a,b:integer;
     count,j:integer;
function palindr (n:integer):boolean;
var s:string;
     i:integer;
begin
  palindr:=false;
  str (n,s);
    for i:=1 to length(s) div 2 do   
      if s[i]=s[length(s)-i+1] then palindr:=true else
        begin
           palindr:=false;
           break;
        end;

Ответить

Другие вопросы из категории

Решите, желательно таблицей
Помогите, пожалуйста решить задачу!!!

Сосуды цилиндрической формы заполнены до краёв жидкостью плотностью d= 1200 кг/м (кубический). Составить программу, которая вычисляет:


а) давление столба жидкости на дно сосудов p=dgh (g= 9,8 м/с (в квадрате));
б) массу жидкости в каждом сосуде m=dV=dhS (S=3,14R (в квадрате));
в) суммарную массу жидкости.

Читайте также

Помогите пожалуйста срочно нужно!!!! 1) программа для определения объема и площади поверхности шара. Вот формула если что S=4ПR², V=¾ΠR²

2) программа проверяет является ли введенное число нечетным и при этом делится на 5
3) задача нахождения факториала числа
ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО!!!!!

Дано трехзначное число. Проверить, является ли число палиндромом, т.е. числом, которое читается одинаково слева направо и справа налево (число единиц

может превосходить число сотен). Если не является, то вывести ближайшее следующее число-палиндром.

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "Проверить, является ли введенное", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.