Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны два целых числа A и B (A < B). Вывести все целые числа, расположенные между данными числами (включая сами эти числа), в порядке их

5-9 класс

убывания, а также количество N этих чисел.

Misterpatriot1992199 01 янв. 2014 г., 10:41:13 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Welikanowa23
01 янв. 2014 г., 12:06:52 (10 лет назад)

var

  A, B, N, i: integer;

 

begin

  N:= 0;  //Обнуляем счетчик

  writeln('Введите числа A и B');

  readln(A, B); //Вводим А и B

  if A < B then  {Если А < B, то печатаем числа начиная с B и заканчивая A, 

иначе наоборот}

    for i:= B downto A do

    begin

      write(i, '  ');  //Печатаем i

      inc(N);  //Увеличиваем счетчик на 1

    end

  else 

    for i:= A downto B do

    begin

      write(i, '  ');

      inc(N);

    end;

  writeln;

  writeln('Количество N этих чисел равно:  ', N);  //Выводим N

end.

Если все правильно, отметь решение как лучшее)

    

Ответить

Другие вопросы из категории

1. Каков был бы диапазон значений целых чисел, если бы для их хранения использовалась 4-разрядная ячейка?

2. Запишите внутреннее представление следующих десятичных чисел, используя 8-разрядную ячейку:

а) 64 б) -120 в) -96 г) 57

а)

б)

в)

г)

3. Запишите внутреннее представление следующих десятичных чисел, используя 16-разрядную ячейку:

а) -15098 б) 6524 в) -28987

а)

б)

в)

4. Определите, каким десятичным числам соответствуют следующие двоичные коды 8-разрядного представления целых чисел:

а) 00100111 б) 11001110 в) 10101010 г) 01111110

а)

б)

в)

г)

Решите пожалуйста задачи как в Поскале.

1. Верно ли , что треугольник равнобедренный?
2. Верно ли , что число А кратно 3?

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

Можно на языке java: дан массив размера N. Вывести его элементы в обратном порядке. И еще одна: даны два целых числа А и В(А<В). Вывести в порядке возра

ствния все целые числа расположенные между ними(включая сами числа)а так же кол-во N этих чисел, заранее благодарю

Даны два целых числа A и B (A < B). Вывести в порядке убывания все

целые числа, расположенные между A и B (не включая числа A и B), а
также количество N этих чисел.

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,



Вы находитесь на странице вопроса "Даны два целых числа A и B (A &lt; B). Вывести все целые числа, расположенные между данными числами (включая сами эти числа), в порядке их", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.