Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль

10-11 класс

Проверить, будет ли файл, состоящий из целых чисел симметричен.
(первый символ должен быть равный последнему, второй символ равен предпоследнему и т.д)

Ludmilka8283 22 нояб. 2013 г., 8:49:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lego12
22 нояб. 2013 г., 9:59:46 (10 лет назад)

Uses crt;
var
i,sum,kvad:integer;
mas:array [1..10] of integer;
begin
for i:=1 to 10 do
mas[i]:=random (100);
for i:=1 to 10 do
write(mas[i],' ');
for i:=1 to 10 do
sum:=sum+mas[i];
if sum mod 2=0 then
writeln('sum=',sum,' summa 4etna9')
else
writeln('sum=',sum,' summa ne 4etna9');
for i:=1 to 10 do
kvad:=kvad+mas[i]*mas[i];
if kvad>9999 then
writeln('kvad=',kvad,' p9tizna4noe')
else
writeln('kvad=',kvad,' ne p9tizna4noe');
read;
end.

Ответить

Другие вопросы из категории

Помогите написать программу на VBA пожалуйста

Дан целочисленный массив. Напечатать те его элементы, индексы которых являются степенями двойки (1,2,4,6,8 и т. д.)

Определите значение целочисленной переменной S после выполнения опеhаторов: нц для i от 1

до 2 S := 0 нц для j 2 до 3 нц для k 1 до 2 S := S+i+j+k кц кц кц
Помогите, не сходится никак с ответом

1 Определить максимальное количество страниц текста, содержащего по 80 символов в каждой строке и 64 строки на странице, которое может содержать файл,

сохраненный на диске объемом 126 Кбайт
2 Для хранения изображения размером 128*128 точек выделено 16 Кбайт памяти. Определите, какое максимальное число цветов а палитре

Читайте также

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

ПАСКАЛЬ!

как на языке паскаль записать
корень5x - корень4y +1
??

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;



Вы находитесь на странице вопроса "Паскаль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.