Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Как применить random вместо readln?

10-11 класс

program pr9;
type mas= array[-10..10] of integer;
const n = 5;var s,i:integer;a:mas;
begin
writeln('Номера четных отрицательных элементов:');
s:=0;
for i:=1 to n do begin
readln(a[i]);
end;
for i:=1 to n do begin
if (a[i]<0)and(a[i] mod 2=0)then
begin
write(i,' ');
s:=s+a[i];
end;
end;
writeln;
writeln('Их сумма=',s);
end.

Vladbond1996 15 июля 2015 г., 9:55:43 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Юлия28042004
15 июля 2015 г., 11:10:07 (8 лет назад)

program pr9;
type mas = array[-10..10] of integer;
const n = 5;
var s, i:integer;
a:mas;
begin
     randomize;
     writeln('Номера четных отрицательных элементов:');
     s := 0;
     for i := 1 to n do
     begin
          a[i] := random(1000) - 500;{Числа рандомизируются от -500 до 500}
     end;
     for i:=1 to n do
     begin
          write(a[i], ' ');
     end;
     for i:=1 to n do
     begin
          if (a[i] < 0) and (a[i] mod 2 = 0)
          then
          begin
               write(i, ' ');
               s := s + a[i];
          end;
     end;
     writeln;
     writeln('Их сумма = 

Ответить

Другие вопросы из категории

Запишите в развернутой форме 1)1*2^5+0*2^4+0*2^+1*2^2+0*2^1+1*2^+1*2^-1 2)A*16^3+7*16^2+1*16^1+4*16^0+5*16^-1+7*16^-2

Какое число записано римскими цифрами ZZMCDXXV

1)

У Толи есть доступ к сети Интернет по
высокоскоростному одностороннему радиоканалу, обеспечивающему скорость
получения информации 219 бит в секунду. У Миши нет скоростного
доступа в Интернет, но есть возможность получать информацию от Толи по
низкоскоростному телефонному каналу со средней скоростью 215 бит в
секунду. Миша договорился с Толей, что тот будет скачивать для него данные
объемом 5 Мбайт по высокоскоростному каналу и ретранслировать их Мише по
низкоскоростному каналу. Компьютер Толи может начать ретрансляцию данных не
раньше, чем им будут получены первые 512 Кбайт этих данных. Каков минимально
возможный промежуток времени (в секундах) с момента начала скачивания Толей
данных до полного их получения Мишей? В ответе укажите только число, слово
«секунд» или букву «с» добавлять не нужно.

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.

Читайте также

1 как называется диск. накопитель,

с которого загружается операц.система?
а boot drive
b boot diskette
c boot partition
2 название формата графич. изображ., используемого в ос windows
a pdf
b xml
c bmp
3 название начальной записи на диске, где записана информация необходимая ос для работы с диском
a bootstrap
b boot partition
c boot-sector
4программа wine предназначена для выполнения функции:
а для настройки и запуска ssh-сервера
b для запуска windows-программ в ос Linux
c для запуска эмулятора virtual box
d для запуска VMware
e для запуска граф. интерфейса gnome os Linux
5 порция информации, оставляемая на компьютере веб-клиента программой, запущенной на стороне веб-сервера. применяется для сохранения данных, специфичных для данного клиента.
a вирус-шпион trojan-spy.win32
b cookie
c вирус блокиратор программ-браузеров
d вирус баннер
6 как называется стандарт памяти и технология,приводящие к удвоению скорости передачи данных между памятью и процессором?
а dds
b dec
c ddr
d dsl
7как называется программный компонент, который позволяет взаимодействовать с устройствами компьютера
а dsl
b dream weaver
c deriver
d dynamic languages
8как называется информационный барьер, запрещающий доступ к защищаемой сети всех протоколов кроме разрешеных
a flash
b firewall
c file fragmentation
d fire wire
9 протокол передачи данных между компьютерами. в качестве транспортного механизма для передачи используется протокол tct
a Bluetooth
b wifi
c ftp
d irDA
12. как называется стандарт интерфейса в беспроводной связи?
а ieee
b ieee 802.11
c igmp
d ieee 802.11 b/g/n
14 назовите программу для создания презентации, аналог powerpoint mo
a draw
b impress
c math
d base
17 технология преобразования множества внутренних ip адресов сети в внешние адреса, используемые для связи с Интернет?
a dns
b http
c nat
d ip v4
18. в этих аккумуляторах вместо ядовитого кадмия применяются соединения металлов с водородом
а li-ion soni Ericsson
b li-полимерные Nokia
c никель-металлогидридные gp
20 какая программа, расширяет возможности какого-нибудь программного пакета
a playlist
b plug-in
c portable soft
d pe - file
21 специальный формат файлов, разработанный корпорацией Microsoft для обмена форматированными текст.документами
a txt
b djvu
c rtf
d pdf
e fb2
22 как называются разъемы для установки на системную плату различных типов процессоров семейств 486, pentium и pentium pro
a sosket 7
b sosket 478
c sosket 1-8
d sosket 486
23 какая программа не является эмулятором ос
а qemu
b virtual box
c moba liveCD
d VMware player
g wine
24 какую функцию осуществляет файл с расширением vmdk
a описание параметров виртуального жесткого диска
b главный конфигурац. файл виртуальной ос
c постоянная память ram
d файл подкачки виртуальной машины
25 какой оценочный период установлен, для пользователя, в компьютерной программе Microsoft virtual pc 2007
a бесплатное пользование 30 дней
b бп 60 дней
c бп 10 дней
d период пользования не установлен
е требуется оплата при установки

Как заменить программму в турбо паскале чтоб она решалась в паскале ABC? program kRUGI;

uses crt;
var gd,gm,c,i,r,x,y,n:integer;
begin
clrscr;
randomize;
writeln('введите колличество окружностей->');
readln(n);
gd:=0;
for i:=1 to n do begin
r:=random(80);x:=random(600);y:=random(400);
c:=random(15);setcolor(c);
circle(x,y,r);
setfillstyler(1,c);floodfill(x,y,c);
end;
readkey;
closegraph;
end.

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.

Олимпиадные задачи требуют ввод-вывод данных с использованием внешних файлов как это сделать? ИНФОРМАТИКА конспекты уроков 9-11 классы Чернов

А.А. с198

program pr;

uses crt;

var f:file of integer;

n:integer;

a:string;

begin

clrscr;

a:='c:\f1.txt';

assign(f,a);

rewrite(f);

writeln('n: ');

readln(n);

write(f,n);

close (f);

readln;

end.

после выполнения программы в файле f1.txt вместо значения n=5 появилось -256

что не так ?



Вы находитесь на странице вопроса "Как применить random вместо readln?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.