Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны две последовательности целых чисел: a_1,a_2,…,a_8 и b_1,b_2,…,b_8 . Найти количество четных чисел в первой из них и количество нечетных во второй.

10-11 класс

(Определить функцию, позволяющую распознавать четные числа).

Даша2003адидас 03 июля 2013 г., 5:05:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ololol4545
03 июля 2013 г., 7:41:57 (10 лет назад)

// Код на паскале

 

var

  a, b: array [1 .. 8] of longint;

  i, ans1, ans2: byte; 

 

function check(var x: longint): boolean; // функция проверки числа на четность

begin

  if x mod 2 = 0

    then check := true

  else

    check := false;

end;

 

begin

  ans1 := 0;

  ans2 := 0;

  for i := 1 to 8 do

  begin

    read(a[i]);  //читаем число а_і

    if check(a[i]) then //если четное, то ...

      inc(ans1);  //увеличиваем ответ_1 на 1

  end;

  for i := 1 to 8 do

  begin

    read(b[i]);   //читаем число b_i

    if not check(b[i]) then  // если нечетное, то ...

      inc(ans2); // увеличиваем ответ_2 на 1

  end;

  writeln('Количество четных чисел в первой последовательности = ', ans1);

  writeln('Количество нечетных чисел во второй последовательности = ', ans2);

end.

+ 0 -
Ксения
03 апр. 2017 г., 16:35:25 (7 лет назад)

А можно то же самое, только в C# и через методы, без массива?

Ответить

Другие вопросы из категории

Написать программу Паскаль, которая б вычисляла сумму процентов начисленных в банке под 18% на срок - 1 год.

Входные данные: сумма.
Выходные данные: сумма процентов.

Читайте также

ЗАДАЧА В ПАСКАЛЕ дана непустая последовательность целых чисел оканчивающаяся нулем.найти: а) наибольшее число б) разность

максимального и минимального

в) максимальный элемент из стоящих на четных местах

г) сумму положительных и среднее арифметическое отрицательных

д) второй максимум

е) длину наибольшего фрагмента, состоящего из одинаковых элементов.

ЗАРАНЕЕ ОГРОМНОЕ СПАСИБО ЗА РЕШЕНИЕ ХОТЯ БЫ ОДНОЙ ИЗ ЗАДАЧЕК...))))))

Вводится последовательность целых чисел, по абсолютной величине меньших или равных 100.Найти и вывести на печать максимальный элемент и число

отрицательных элементов, расположенных после первого нулевого элемента.
Кто может плз очень срочно решить,желательно без массивов,но если не выйдет то через них.На языке Turbo Pascal

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.



Вы находитесь на странице вопроса "Даны две последовательности целых чисел: a_1,a_2,…,a_8 и b_1,b_2,…,b_8 . Найти количество четных чисел в первой из них и количество нечетных во второй.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.