Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано натуральное число n определите количество цифр в цифровой записи его числа,которые имеют наибольшее значение пример N=1808,количество чифр с

1-4 класс

наибольшим значением равно 2(две циры 8)

Basonia 24 авг. 2015 г., 6:24:11 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АлисаСеменякина
24 авг. 2015 г., 8:39:57 (8 лет назад)

var n, amount, max_digit, copy_of_n: integer;
begin
     read(n);
     copy_of_n := n;
     amount := 0;
     max_digit := copy_of_n mod 10;
     while copy_of_n <> 0 do
     begin                                   {Находим наибольшую цифру в числе}
          if max_digit < copy_of_n mod 10
          then
              max_digit := copy_of_n mod 10;
          copy_of_n := copy_of_n div 10;
     end;
     copy_of_n := n;
     while copy_of_n <> 0 do        {Считаем количество таких цифр}
     begin
          if copy_of_n mod 10 = max_digit
          then
              amount := amount + 1;
          copy_of_n := copy_of_n div 10;
     end;
     writeln(amount);
end.

Ответить

Другие вопросы из категории

Впишите в клеточки слова-ответы

а) Сторона, передающая информацию.
2 строчки.
б) Сторона, принимающая информацию.
2 строчки.
в) Система обмена сообщениями (письмами) с помощью компьютерных сетей.
2 строчки.

Запишите название обратного алгоритма и допишите его команды. Наполните грелку 1) Начало 2)Возьми чайник 3)Налей воду 4)Согрей воду 5)Вылей воду из

чайника в грелку 7)поставь чайник на место 8)Конец. (Название обратного алгоритма: тоже напишите) 1)Начало 2)... 3)... 4).. 5).. 6).. 7).. 8) Конец

Читайте также

Дан массив L(15), определить количество и сумму чисел, кратных числу 3. Вывести результат и массив L.

Ребятушки, пишите те, кто реально может помочь. Очень прошу)))
это ТурбоПаскаль

Вася сосчитал количество цифр на клавиатуре с рисунка, из него вычел количество "F" (заглавных и строчных) на всех клавишах, умножил полученное число на

количество стрелок и прибавил количество букв русского алфавита, начертание которых на клавиатуре совпадает с начертанием некоторых букв английского алфавита на клавиатуре. Какое число получилось у Васи?

Вася сосчитал количество цифр на клавиатуре из него вычел количество букв "F" (заглавных и строчных) на всех клавишах умножил полученное число на

количество стрелок и прибавил количество букв русского алфавита, начертание которых на клавиатуре совпадает с начертанием некоторых букв английского алфавита на клавиатуре. Какое число получилось у Васи, если он не допустил ошибок



Вы находитесь на странице вопроса "дано натуральное число n определите количество цифр в цифровой записи его числа,которые имеют наибольшее значение пример N=1808,количество чифр с", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.