Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

ПОМОГИТЕ НАПИСАТЬ В ПАСКАЛЕ :Любое целое число может быть выражено через k троек и m

10-11 класс

пятерок: n = k⋅3+m⋅5. Найти для заданного числа n значения k и m.
ЗА РАНИЕ СПАСИБО

Wolf09876 11 июля 2013 г., 14:57:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vadimmasjagin
11 июля 2013 г., 17:04:43 (10 лет назад)

var
  n: longint;
  k, m: integer;

begin
  Write('Введите натуральное число (5 и более): ');
  Readln(n);
  for m := 1 to (n div 5) do
    for k := 1 to (n div 3) do
      if (3 * k + 5 * m) = n then Writeln('3x', k, '+5x', m);
end.

Тестовое решение:
Введите натуральное число (5 и более): 142
3x44+5x2
3x39+5x5
3x34+5x8
3x29+5x11
3x24+5x14
3x19+5x17
3x14+5x20
3x9+5x23
3x4+5x26

Более "красивый" вариант:

var
  n: longint;
  k, m: integer;

begin
  Write('Введите натуральное число (5 и более): ');
  Readln(n);
  for m := 1 to (n div 5) do
    begin
    k:=(n-5*m) div 3;
    if (3 * k + 5 * m) = n then Writeln('3x', k, '+5x', m)
    end
end.

Тестовое решение:
Введите натуральное число (5 и более): 142
3x44+5x2
3x39+5x5
3x34+5x8
3x29+5x11
3x24+5x14
3x19+5x17
3x14+5x20
3x9+5x23
3x4+5x26



Ответить

Другие вопросы из категории

Помогите, очень нужно.

Нужно найти переменную i

1.Сколько бит информации содержится в сообщении объемом половина килобайта?

2.Сколько байт информации содержит сообщение объемом 0,25 Кбайт
3.Сколько Кбайт информации содержит сообщение объемом 2^16 бит
4.Сколько Мбайт информации содержит сообщение объемом 2^25 бит?
5.Сколько Гбайт информации содержит сообщение объемом 2^37бит?

задания по паскалю Даны координаты двух различных полей шахматной доски х1, y1, x2, y2 (целые числа, лежащие в диапазоне 1-8). Проверить

истинность высказывания: «Данные поля имеют одинаковый цвет».

помагите решить

Читайте также

Помогите написать в паскале!

Ввести три целых числа
x, y, z. Если хотя бы одно из них четное,

то
первому четному числу присвоить значение произведения этих чисел.



Сообразил только как определить чётное или нечётное число а как дальше не могу понять!


program Lab2;
var x,y,z: integer;
Begin

Writeln ('Введите число');
Readln (x);
if x mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (y);
if y mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (z);
if z mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');
end.








Помогите написать в паскале!

Ввести три целых числа x, y, z. Если хотя бы одно из них четное,

то первому четному числу присвоить значение произведения этих чисел.

Помогите написать задачу на паскале

================================================================
В одной берляндской школе появился новый ученик Вася, который очень сильно любил химию. К сожалению для учителя химии, Вася принебрегал техникой безопасности и любил смешивать все реагенты подряд. В кабинете химии находится n реагентов. Каждый реагент характеризуется целым числом - своей опасностью. При смешивании реагентов действовали такиме правилами:

смешивать можно только 2 реагента;
при смешивании реагентов, старые реагенты исчезали и появлялся новый реагент, опасность которого равнялась среднему арифметическому старых.

Известно, что Вася собирается смешивать реагенты до тех пор, пока не останется 1 реагент. Помогите учителю химии определить максимально возможную опасность окончательного реагента.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.



Вы находитесь на странице вопроса "ПОМОГИТЕ НАПИСАТЬ В ПАСКАЛЕ :Любое целое число может быть выражено через k троек и m", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.