Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer):integer; var p,i:integer; begin p:=1;

10-11 класс

for i:=1 to n do p:=p*i; factorial:=p; end;

Dazen 01 апр. 2014 г., 13:20:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Milkimaniya
01 апр. 2014 г., 15:10:53 (10 лет назад)

Program p1;

uses crt;

function factorial (n:integer):integer; var p,i:integer; begin p:=1; for i:=1 to n do p:=p*i; factorial:=p; end;

var n:integer;

begin

 Write('Введите число, n=');

 Readln(n);

 Writeln('Факториал  = ',factorial(n));

end.

Ответить

Другие вопросы из категории

вычислить через оператор IF
На интервале [1:1000] надо найти количество чисел, у которых сумма цифр в десятичной и троичной системе счисления совпадают. Ответ записать в

десятичной системе счисления. В ответе укажите только число без единиц измерения.

Что осуществляет служба DNS ?

1) маршрутизацию пакетов передачи данных
2) управление сетью Интернет
3) хранение IP-адресов узлов сети
Помогите пожалуйста

сведения о каждом из 6555 сотрудников фирмы хранится в виде строки из 2100 символов ( в виде таблицы). определить минимальное количество дискет емкостью

1,44 мега байт каждая, на которое можно разместить сведения обо всех сотрудниках.

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

эллементы массива вычисляются по формуле A(X,Y)=2X^2-Y^2 написать программу, которая выводит на экран значения элементов массива А(2,2).

подсчитать количество отрицательных элементов

сумму положительных элементов

ВЫВОДИТ НА ЭКРАН НОМЕРА ВСЕХ ЭЛЕМЕНТОВ, ЗНАЧЕНИЯ КОТОРЫХ =0

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

1)Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру.

2)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
3)Напишите программу, которая выводит в одну строчку все делители переданного ей числа, разделяя их пробелами.
4)Напишите программу, которая выводит в столбик цифры введённого числа, начиная с первой. Используйте процедуру.



Вы находитесь на странице вопроса "напишите программу, которая выводит на экран значение n! включая следующую функцию function factorial (n:integer):integer; var p,i:integer; begin p:=1;", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.